Bug 2519 - Xcode integration does not work at all
Summary: Xcode integration does not work at all
Status: CLOSED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 2.9.x
Hardware: PC Mac OS
: Highest blocker
Target Milestone: master
Assignee: Alan McGovern
URL:
Depends on:
Blocks:
 
Reported: 2011-12-15 06:59 UTC by Alan McGovern
Modified: 2015-08-20 03:24 UTC (History)
3 users (show)

Tags: resolver
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description Alan McGovern 2011-12-15 06:59:18 UTC
1) Create a Storyboard based Master-Detail iPhone project.
2) Double click on the .storyboard file to open in Xcode
3) 
MonoDevelop.MacDev.ObjCIntegration.ObjectiveCGenerationException: Could not generate outlet 'DetailItem' in class 'MAster.DetailViewController' as its type 'System.String' could not be resolved to Obj-C
  at MonoDevelop.MacDev.ObjCIntegration.NSObjectTypeInfo.GenerateObjcType (System.String directory, System.String[] frameworks) [0x001e8] in /Users/alanmcgovern/Projects/monodevelop/main/src/addins/MonoDevelop.MacDev/ObjCIntegration/NSObjectTypeInfo.cs:159 
  at MonoDevelop.MacDev.XcodeSyncing.XcodeSyncedType.SyncOut (MonoDevelop.MacDev.XcodeSyncing.XcodeSyncContext context) [0x00000] in /Users/alanmcgovern/Projects/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeSyncedType.cs:64 
  at MonoDevelop.MacDev.XcodeSyncing.XcodeMonitor.UpdateProject (IProgressMonitor monitor, System.Collections.Generic.List`1 allItems, MonoDevelop.MacDev.XcodeIntegration.XcodeProject emptyProject) [0x00324] in /Users/alanmcgovern/Projects/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeMonitor.cs:137 
  at MonoDevelop.MacDev.XcodeSyncing.XcodeProjectTracker.UpdateXcodeProject (IProgressMonitor monitor) [0x00000] in /Users/alanmcgovern/Projects/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeProjectTracker.cs:318
Comment 1 Alan McGovern 2011-12-15 08:57:56 UTC
Fixed, some boolean expressions were inverted accidentally in the branch.
Comment 2 Atin 2011-12-29 01:09:38 UTC
We go with provided steps and don't get any error.

Please close this issue.

Environments:
MAC 10.7
Mono Develop 2.8.5 Stable.
Mono Touch 5.0.4 Stable
Mono Framework 2.0.7 Beta
XCode 4.2 iOS5.0
Comment 3 PJ 2012-01-04 12:08:27 UTC
Verified fixed on
MAC 10.7.2
MonoDevelop 2.8.5
MonoTouch 5.0.4
Mono 2.10.8