Bug 25164 - XBuild compatibility with MSBuild when called with no arguments.
Summary: XBuild compatibility with MSBuild when called with no arguments.
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Tools
Classification: Mono
Component: xbuild ()
Version: unspecified
Hardware: PC Mac OS
: --- enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-12-08 16:36 UTC by Marius Ungureanu
Modified: 2018-03-15 10:40 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Marius Ungureanu 2014-12-08 16:36:20 UTC
When calling 'msbuild' in a directory (without specifying the target item), MSBuild does the following:

If only one solution or project file is in the current directory, automatically select it as the build item.

If there multiple items, "error MSB1011: Specify which project or solution file to use because this folder contains more than one project or solution file."

If there is no item: "error MSB1003: Specify a project or a solution file. The current working directory does not contain a project or solution file."

I can happily hack on this if you guys want.
Comment 1 Marek Safar 2018-03-15 10:40:01 UTC
We deprecated xbuild and recommend using msbuild instead. Switching to msbuild will also most likely resolve the issue you reported.