Bug 2516 - Int64.Parse fails with AllowExponent
Summary: Int64.Parse fails with AllowExponent
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: 2.10.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-12-15 05:45 UTC by Michael Ganss
Modified: 2012-02-21 06:31 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Michael Ganss 2011-12-15 05:45:44 UTC
This is similar to https://bugzilla.novell.com/show_bug.cgi?id=542464 but for long. It works on Microsoft .NET.

csharp> int.Parse("1e3", System.Globalization.NumberStyles.AllowExponent);
1000
csharp> long.Parse("1e3", System.Globalization.NumberStyles.AllowExponent);     System.FormatException: Input string was not in the correct format: Did not parse entire string. pos = 1 s.Length = 3
  at System.Int64.Parse (System.String s, NumberStyles style, IFormatProvider provider) [0x00000] in <filename unknown>:0 
  at System.Int64.Parse (System.String s, NumberStyles style) [0x00000] in <filename unknown>:0 
  at Class14.Host (System.Object& $retval) [0x00000] in <filename unknown>:0 
  at Mono.CSharp.Evaluator.Evaluate (System.String input, System.Object& result, System.Boolean& result_set) [0x00000] in <filename unknown>:0 
  at Mono.CSharpShell.Evaluate (System.String input) [0x00000] in <filename unknown>:0
Comment 1 Marek Safar 2012-02-21 06:31:02 UTC
Fixed in master