Bug 25074 - [System.ComponentModel.DataAnnotations] Imported code from MS referencesource causes test failures
Summary: [System.ComponentModel.DataAnnotations] Imported code from MS referencesource...
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: master
Hardware: PC All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-12-04 11:44 UTC by Alexander Köplinger
Modified: 2014-12-11 20:24 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alexander Köplinger 2014-12-04 11:44:11 UTC
The following tests in System.Web.DynamicData started failing when DataAnnotations was imported from referencesource:

MetaColumnTest.Attributes
MetaColumnTest.DefaultValue
MetaColumnTest.Description
MetaColumnTest.DisplayName 

A quick investigation showed that the returned attributes by AssociatedMetadataTypeTypeDescriptor for the  FooWithMetadataType only include the attributes from FooMetaDataType and not from FooWithMetadataType merged with  FooMetaDataType.

A temporary fix is to bring back the original Mono code: https://github.com/mono/mono/pull/1440
Comment 1 Alexander Köplinger 2014-12-11 20:24:38 UTC
This is now fixed by the recent commits in master.