Bug 2496 - Reproduceable file inconsistency between monodevelop and Xcode
Summary: Reproduceable file inconsistency between monodevelop and Xcode
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: unspecified
Hardware: Macintosh Mac OS
: Low normal
Target Milestone: ---
Assignee: Alan McGovern
URL:
Depends on:
Blocks:
 
Reported: 2011-12-14 10:00 UTC by Henning
Modified: 2012-05-02 12:06 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Henning 2011-12-14 10:00:40 UTC
Hi,

1. Create new UITableViewController with xib file in Xcode and save, switch to Monodevelop let it update the files.

2. Then switch back to Xcode delete the files that were created.

3. Then create a new UI View Controller file with the same name as the UITableViewController before. 

4. Switch back to Monodevelop and see that it does not recognize the change so the old file is still a UITableViewController.

If you need further information don´t hesitate to ask me.

Kind regards


Henning
Comment 1 Miguel de Icaza [MSFT] 2012-04-24 12:33:11 UTC
Would you mind creating a screencast of the problem?
Comment 2 Henning 2012-05-02 02:56:36 UTC
Hi Miguel,

I can no longer reproduce this because in the newest XCode one does not have the option to create a uiviewcontroller or a uitableviewcontroller. Instead you start a new UIView and than add the wanted controller to it. 

So this bug can be considered obsolete or fixed..

Thanks!

PS: I changed the status to resolved -> Fixed
Comment 3 Mikayla Hutchinson [MSFT] 2012-05-02 12:06:57 UTC
Thanks for the update!