Bug 24931 - ListView in StackLayout Mess Binded Images
Summary: ListView in StackLayout Mess Binded Images
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-11-29 06:56 UTC by sedatsen
Modified: 2014-11-30 10:19 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample project and screen captures (4.45 MB, application/x-zip-compressed)
2014-11-29 06:56 UTC, sedatsen
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description sedatsen 2014-11-29 06:56:05 UTC
Created attachment 8909 [details]
Sample project and screen captures

ListView in StackLayout mess binded images in ItemTemplate/DataTemplate/ViewCell.

Sometimes in the first run, sometimes after rotating the device, some of the images do not show correctly. In this simple project I have 12 list items. Every item has an image and a label. Images shows corresponding numbers. Normally images should be ordered. But from time to time; first, last or any other image (or images) display incorrectly (it displays another image from the resources). In the attached screen captures some number images are incorrect but their labels are correct.

When I remove StackLayout and just use ListView no more messing occur. Everyhing works fine. I have spend one day to figure out the problem and finally noticed that the surrounding StackLayout is causing this problematic behavior.

Sometimes it takes too much time to mess up the display (after ten or more rotations).
Comment 1 sedatsen 2014-11-30 10:19:27 UTC
Xamarin Forms 1.3 Pre release fixed the problem.