Bug 24910 - Nullable properties throw Property not found exception
Summary: Nullable properties throw Property not found exception
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.3
Hardware: PC All
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-11-28 01:25 UTC by Prabakaran
Modified: 2015-06-22 10:54 UTC (History)
7 users (show)

Tags: ac bindings xaml
Is this bug a regression?: ---
Last known good build:


Attachments
Sample (74.12 KB, application/zip)
2014-11-28 01:28 UTC, Prabakaran
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Prabakaran 2014-11-28 01:25:16 UTC
Hi,

When we set any value to nullable properties in XAML page, it throw property not found exception. I have prepared a simple sample for you reference, in that sample i have declared Rating property of type nullable int in CustomButton class which is inheriting from Button. Please find the sample in attachment.

Thanks,
Prabakaran R.
Comment 1 Prabakaran 2014-11-28 01:28:01 UTC
Created attachment 8898 [details]
Sample
Comment 2 Sadik Ali 2014-12-01 08:12:25 UTC
 have checked this issue with the sample app attached in comment 1 and getting exception 'Xamarin.Forms.Xaml.XamlParseException: Position 7:43. No Property of name Rating found'. To reproduce this issue I have followed the steps mentioned below.

1. Open the 'Sample App' attached in comment 1 in XS.
2. Set the android project as start-up.
3. Run the app and got the exception.

Screencast : 
Application Output : https://gist.github.com/Udham1/ea778585640671b190c6

Environment Info : 

Xamarin.Forms : 1.2.3.6257

=== Xamarin Studio ===

Version 5.5.4 (build 15)
Installation UUID: ce927b2a-2c07-44c5-b186-09cfdafba6dc
Runtime:
	Mono 3.10.0 ((detached/92c4884)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000031

=== Xamarin.Android ===

Version: 4.20.0.28 (Enterprise Edition)
Android SDK: /Users/xamarin76/Desktop/android-sdk-macosx
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.0    (API level 11)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Apple Developer Tools ===

Xcode 6.1 (6602)
Build 6A1052c

=== Xamarin.Mac ===

Version: 1.11.1.89 (Enterprise Edition)

=== Xamarin.iOS ===

Version: 8.4.0.43 (Enterprise Edition)
Hash: 840a925
Branch: 
Build date: 2014-11-16 21:03:22-0500

=== Build Information ===

Release ID: 505040015
Git revision: f93940a35458a18052f1a25e106e62ca970d9c40
Build date: 2014-11-19 15:32:41-05
Xamarin addins: dc23cbd91a3a0e1d326328e1229e86c942a49ec8

=== Operating System ===

Mac OS X 10.9.4
Darwin Xamarin76s-Mac-mini.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 3 Sadik Ali 2014-12-01 08:48:09 UTC
An update to the comment 2 : 
Please refer screencast : http://www.screencast.com/t/LW4FwBj9
Comment 4 Jason Smith [MSFT] 2015-06-11 16:47:55 UTC
Should be fixed in 1.4.3 final
Comment 5 Parmendra Kumar 2015-06-22 10:54:03 UTC
I have checked this issue with xamarin.forms.1.4.3.6364-pre3 and its working fine at my end.

Hence closing this issue.

Environment: 
Xamarin Studio  5.9.3 (build 1)
Mono 4.0.1 ((detached/ed1d3ec)
GTK+ 2.24.23 (Raleigh theme)
Package version: 400010044
Xcode 6.2 (6776)
Xamarin.iOS: 8.10.1.64 (Enterprise Edition)
Xamarin.Android: 5.1.3.1 (Enterprise Edition)
Xamarin.Mac: 2.0.1.64 (Enterprise Edition)
Mac OS X 10.9.4