Bug 24834 - IsClippedToBounds doesn't work in a Grid control
Summary: IsClippedToBounds doesn't work in a Grid control
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.3
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 24832 ()
Depends on:
Blocks:
 
Reported: 2014-11-26 06:14 UTC by Alex
Modified: 2016-03-25 18:41 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
a project for reproducing (3.81 MB, application/zip)
2014-11-26 06:15 UTC, Alex
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alex 2014-11-26 06:14:36 UTC
I have a ScrollView control, which is located in a Grid control. For this Grid
I set the IsClippedToBounds property to true. If this Grid is located in
ContentView, all works as expected (ScrollView is clipped well). However, if I
put this Grid into another Grid, ScrollView isn't clipped at all in iOS and
Android. I've attached a sample project that illustrates this problem.
Comment 1 Alex 2014-11-26 06:15:53 UTC
Created attachment 8875 [details]
a project for reproducing
Comment 2 Bill Holmes 2014-12-08 13:25:18 UTC
*** Bug 24832 has been marked as a duplicate of this bug. ***
Comment 3 Rajneesh Kumar 2014-12-22 06:25:54 UTC
I have checked this issue and with the help of attached sample I am able to reproduce this issue.

I am getting this behavior with iOS project but I am unable to reproduce this issue with android project.

Screencast: http://www.screencast.com/t/7ciTzmnncqF

If you have chance, could you please provide build info and screencast of android project. So that we can reproduce this behavior for android as well.

Environment Info:

Xamarin.Forms:1.2.3.6257

=== Xamarin Studio ===

Version 5.7 (build 660)
Installation UUID: 6ea47b0d-1852-4aaf-808d-373ff0a5002b
Runtime:
	Mono 3.12.0 ((detached/c82a2e5)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000070

=== Apple Developer Tools ===

Xcode 6.1 (6604)
Build 6A1052d

=== Xamarin.iOS ===

Version: 8.6.0.41 (Trial Edition)
Hash: 2c57f4e
Branch: 
Build date: 2014-12-18 16:42:49-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Trial Edition)
Android SDK: /Users/jatin66/Desktop/Backup/android-sdk-macosx
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin.Mac ===

Version: 1.10.0.18 (Starter Edition)

=== Build Information ===

Release ID: 507000660
Git revision: 6a74f9bdb90d9415b597064d815c9be38b401fee
Build date: 2014-12-18 00:38:00-05
Xamarin addins: 57be0f5e1433cb58b70ea9b52e9dc77ad791be40

=== Operating System ===

Mac OS X 10.10.0
Darwin Jatin66s-iMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 4 philip 2015-04-18 14:08:57 UTC
I am experiencing similar problems under Android.  IsClippedToBounds either does not seem to be set under some conditions, or the extra views that XF inserts are not all set properly.  At any rate, under some conditions clipping does not work.

I am able to work around this by making a custom Android renderer and settings lipping directly there.  This means that IsClippedToBounds is not properly propagating to the android views.

This is an old bug and was reproduced under IOS.  Any chance for a fix?
Comment 5 Jason Smith [MSFT] 2016-03-25 18:41:31 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we no longer believe it affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team