Bug 24804 - Android 5 not renders NavigationPage with a black bar at the bottom.
Summary: Android 5 not renders NavigationPage with a black bar at the bottom.
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.3
Hardware: Other Other
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL: http://forums.xamarin.com/discussion/...
Depends on:
Blocks:
 
Reported: 2014-11-25 09:41 UTC by Narcís Calvet
Modified: 2015-06-22 14:55 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Narcís Calvet 2014-11-25 09:41:48 UTC
Using a NavigationPage with Android 5 plots a black bar at the bottom clipping the part of the NavigationPage that should be rendered on the black bar's area. It works fine in Android 4.*. This can be reproduce with the https://github.com/xamarin/xamarin-forms-samples/tree/master/FormsGallery demo. Another user also posted a very simple example to reproduce it at the forums: http://forums.xamarin.com/discussion/28419/android-navigationpage-bug-a-black-bar-obscures-the-lower-part-of-the-page
Comment 1 Narcís Calvet 2014-11-25 09:47:14 UTC
Forgot to mention that anything loaded in the application from the NavigationPage is also clipped. Easily reproducible with the FormsGallery demo as well.
Comment 2 Ram Chandra 2014-11-25 11:15:00 UTC
I have checked this issue and I am able to reproduce this issue.

Steps to reproduce:

1. Open Forms application in XS.
2. Build and deploy the project in "Android 5" device .

When I deploy the "FormsGallary" application on android 5 device I observed that there is a a black bar obscures the lower part of the NavigationPage and If I rotate the device in landscape mode a black bar (not completely black) obscures the lower part of the NavigationPage. 

I am not getting this behavior with android 4.4.2.

Application output: https://gist.github.com/saurabh360/8e2c958cdf9ff745f894
IDE logs: https://gist.github.com/saurabh360/52b14e6e9cabf2a0e056
Device logs: https://gist.github.com/saurabh360/9342b543fef9bcf63a23

Device Info : Nexus 5 (Android: 5)

Environment Info:

=== Xamarin Studio ===

Version 5.5.4 (build 15)
Installation UUID: 6ea47b0d-1852-4aaf-808d-373ff0a5002b
Runtime:
	Mono 3.10.0 ((detached/92c4884)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000031

=== Xamarin.Android ===

Version: 4.20.0.28 (Trial Edition)
Android SDK: /Users/jatin66/Desktop/Backup/android-sdk-macosx
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.0    (API level 11)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Apple Developer Tools ===

Xcode 6.1 (6604)
Build 6A1052d

=== Xamarin.iOS ===

Version: 8.4.0.43 (Trial Edition)
Hash: 840a925
Branch: 
Build date: 2014-11-16 21:03:22-0500

=== Xamarin.Mac ===

Version: 1.11.0.1 (Trial Edition)

=== Build Information ===

Release ID: 505040015
Git revision: f93940a35458a18052f1a25e106e62ca970d9c40
Build date: 2014-11-19 15:32:41-05
Xamarin addins: dc23cbd91a3a0e1d326328e1229e86c942a49ec8

=== Operating System ===

Mac OS X 10.10.0
Darwin Jatin66s-iMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 3 Shawn Poindexter 2014-12-11 19:14:14 UTC
Here is the minimum amount of code to reproduce the problem on Android 5.0. I confirm this does not work on a Moto X. Just add replace the App class of a blank Forms PCL project with this:

public class App
	{
		public static Page GetMainPage ()
		{	
			return new Xamarin.Forms.TabbedPage {
				Children = {
					new NavigationPage (new ContentPage { 
						Content = new Label { 
							Text = "This is missing on Android 5.0",
							VerticalOptions = LayoutOptions.End
						}
					})
				}
			};
		}
	}


I also can confirm that this is also broken in Xamarin.Forms 1.3.0
Comment 4 Seth Rosetter 2015-06-02 17:34:09 UTC
I have tried to reproduce on a Nexus 10 (device someone in the forums was experiencing this issue with) as well as Nexus 5, both running Android 5.0. I have tested against the attached repro using Xamarin.Forms 1.4.2 and The FormsGallery using targeting Xamarin.Forms 1.4.1. I have been unable to reproduce this. Marking as Needs Info. Can you verify this is no longer an issue for you or reopen with distilled reproduction (zipped .sln, so that I can see the Forms version targets) and specific device information that you were able to reproduce this on?  

Thanks!

-Seth
Comment 5 Narcís Calvet 2015-06-03 03:03:47 UTC
Seth, I think this has been fixed with latest Xamarin.Forms releases as I haven't been able to reproduce it latest updates. In my opinion, this can be closed now.
Comment 6 Seth Rosetter 2015-06-22 14:55:01 UTC
Marking resolved. Thanks!