Bug 24740 - Xaml does not work with Xamarin.Forms on iOS for Shared Projects using file templates
Summary: Xaml does not work with Xamarin.Forms on iOS for Shared Projects using file t...
Status: RESOLVED DUPLICATE of bug 21074
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.0
Hardware: Macintosh Mac OS
: High major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-11-21 13:30 UTC by Mike Bluestein
Modified: 2014-11-24 01:15 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
test case (2.52 MB, application/zip)
2014-11-21 13:30 UTC, Mike Bluestein
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 21074

Description Mike Bluestein 2014-11-21 13:30:47 UTC
Created attachment 8839 [details]
test case

If you create a new Xamarin.Forms project in Xamarin Studio and add a new Content Page using the file template, the project does not build due to the InitializeComponent method not being found. I added a trivial project with no additional user code other than what the template creates to demonstrate this. I think we should remove the shared project template for Xamarin.Forms (at least from stable) until this is fixed so users are not led astray.
Comment 1 Prashant manu 2014-11-24 01:15:22 UTC
We have checked and getting the same error as mentioned in description 'InitializeComponent method not being found'. 

However Issue 21074 already reported for the same 

Supplement Info: 
IDE log: https://gist.github.com/saurabh360/beaad5f8d910408ee135
Build Output: https://gist.github.com/saurabh360/ad663ff7128f344be1bc

Environment Info:
Xamarin Studio
Version 5.5.4 (build 15)
Installation UUID: 0b7eaebc-a0ed-4b58-81df-91e378cad28c
Runtime:
	Mono 3.10.0 ((detached/197d3bb)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000032

Apple Developer Tools
Xcode 6.1 (6604)
Build 6A1052d

Xamarin.Mac
Version: 1.10.0.18 (Business Edition)

Xamarin.iOS
Version: 8.4.0.45 (Business Edition)
Hash: f36d1ed
Branch: 
Build date: 2014-11-18 17:47:28-0500

Xamarin.Android
Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/Admin_Mac/Desktop/Anddk/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

Build Information
Release ID: 505040015
Git revision: f93940a35458a18052f1a25e106e62ca970d9c40
Build date: 2014-11-19 15:32:41-05
Xamarin addins: dc23cbd91a3a0e1d326328e1229e86c942a49ec8

Operating System
Mac OS X 10.10.0
Darwin Admin-Macs-Mac-mini.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64

*** This bug has been marked as a duplicate of bug 21074 ***