Bug 24737 - Problem with Palette GenerateAsync
Summary: Problem with Palette GenerateAsync
Status: RESOLVED FIXED
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: N/A
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jon Dick
URL:
Depends on:
Blocks:
 
Reported: 2014-11-21 13:02 UTC by Rafael Machado
Modified: 2014-12-04 20:32 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Error log (9.44 KB, text/plain)
2014-11-21 13:02 UTC, Rafael Machado
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rafael Machado 2014-11-21 13:02:20 UTC
Created attachment 8838 [details]
Error log

Hello,

When trying to implement the Lollipop Palette.GenerateAsync to get colors from a Bitmap, I'm getting the following error:

Java.Lang.NoClassDefFoundError: Failed resolution of: Landroid/support/v4/os/AsyncTaskCompat;

This error breaks my app. The complete error log is in the attachment.
Comment 1 Jonathan Pryor 2014-11-21 14:18:25 UTC
@Bill: Landroid/support/v4/os/AsyncTaskCompat; is a Support type; is it being included into the .apk?
Comment 2 Jon Dick 2014-12-04 20:32:15 UTC
The Support-v7-Palette nuget package did not have a dependency on Support-v4 which it should have (to prevent this error).  

This has been corrected and will be included in the v21.0.0.0 nuget release of Support-v7-Palette.  In the meantime you could reference support-v4 in your project manually, or simply use the non-async Generate () method (perhaps run it in a Task for a similar result).