Bug 2468 - Deployment crashes
Summary: Deployment crashes
Status: RESOLVED DUPLICATE of bug 2402
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Deployment ()
Version: 2.8.4.1
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-12-12 16:37 UTC by kenny goers
Modified: 2011-12-13 07:04 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 2402

Description kenny goers 2011-12-12 16:37:20 UTC
Description of Problem:
I get the following error when deploying an app to the device.

Steps to reproduce the problem:
1. Open MonoDevelop
2. Deploy iOS app


Actual Results:
/Developer/MonoTouch/usr/bin/mtouch -installdev "/Users/mac/Projects/iFactr/Samples/GenMed/Touch.Container/bin/iPhone/Debug/TouchContainerMT.app"
Please ensure your device is connected...
Connected to: IPAD
Initializing file service...
Uploading application
Finalizing file service...
error MT0000: Unexpected error - Please fill a bug report at http://bugzilla.xamarin.com
System.Exception: AMDeviceStartService returned: 0xe800002d
at MonoTouch.Installation.Device.StartService (MonoTouch.CoreFoundation.CFString) <0x000a7>
at MonoTouch.Installation.InstallationProxyService..ctor (MonoTouch.Installation.Device) <0x0003f>
at MonoTouch.Installation.Installer.InstallApplication (MonoTouch.Installation.Device,string) <0x00027>
at MonoTouch.Installation.Installer/<InstallApplication>c__AnonStorey4.<>m__3 (MonoTouch.Installation.Device) <0x0002f>
at MonoTouch.Installation.Installer/<ExecuteWithSession>c__AnonStorey3.<>m__2 (object,System.EventArgs) <0x000ef>
at MonoTouch.Installation.Device.NotificationCallback (MonoTouch.Installation.Device/am_device_notification_callback_info&) <0x0006e>
at (wrapper native-to-managed) MonoTouch.Installation.Device.NotificationCallback (MonoTouch.Installation.Device/am_device_notification_callback_info&) <0x0003f>
at (wrapper managed-to-native) MonoTouch.CoreFoundation.CFRunLoop.CFRunLoopRun () <0x00003>
at MonoTouch.CoreFoundation.CFRunLoop.Run () <0x0000b>
at MonoTouch.Installation.Installer.ExecuteWithSession (MonoTouch.Installation.Installer/Executor) <0x000d7>
at MonoTouch.Installation.Installer.InstallApplication (string) <0x0006b>
at MTouch.Main2 (string[]) <0x03a57>
at MTouch.Main (string[]) <0x0001f>

The application was terminated by a signal: SIGHUP

Expected Results:
Actual deployment of the APP

How often does this happen? 
Every time!

Additional Information:
Comment 1 Rolf Bjarne Kvinge [MSFT] 2011-12-13 07:04:54 UTC
This has already been reported (and fixed for the next beta).

*** This bug has been marked as a duplicate of bug 2402 ***