Bug 24670 - SetBinding on ActivityIndicator throws a runtime error on Android (iOS seems fine)
Summary: SetBinding on ActivityIndicator throws a runtime error on Android (iOS seems...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-11-19 13:30 UTC by Rob DeRosa
Modified: 2016-03-25 18:31 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rob DeRosa 2014-11-19 13:30:43 UTC
XF - 1.2.3.6257


The following code throws a runtime error on Android:

var activity = new ActivityIndicator();
activity.BindingContext = ViewModel;
activity.SetBinding(ActivityIndicator.IsRunningProperty, "IsBusy");
activity.SetBinding(ActivityIndicator.IsVisibleProperty, "IsBusy");

throws:

System.MissingMethodException: Method not found: 'Xamarin.Forms.BindableObjectExtensions.SetBinding'.
  at TripExpenses.Core.App.GetMainPage () [0x00001] in /Users/Rob/Documents/Projects/Demos/TripExpenses/TripExpenses/TripExpenses/TripExpenses/TripExpenses.Core/App.cs:13
  at TripExpenses.Droid.MainActivity.OnCreate (Android.OS.Bundle) [0x00015] in /Users/Rob/Documents/Projects/Demos/TripExpenses/TripExpenses/TripExpenses/TripExpenses/TripExpenses.Android/MainActivity.cs:25
  at Android.App.Activity.n_OnCreate_Landroid_os_Bundle_ (intptr,intptr,intptr) [0x00011] in /Users/builder/data/lanes/monodroid-mlion-monodroid-4.18-series/5474129a/source/monodroid/src/Mono.Android/platforms/android-19/src/generated/Android.App.Activity.cs:2179
  at at (wrapper dynamic-method) object.0c66d609-eade-4302-86a0-aa44c36579fd (intptr,intptr,intptr) <IL 0x00017, 0x0001f>


------------

=== Xamarin Studio ===

Version 5.5.3 (build 6)
Installation UUID: b29db709-b812-4371-835d-d804f0165289
Runtime:
	Mono 3.10.0 ((detached/e204655)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000023

=== Apple Developer Tools ===

Xcode 6.1 (6604)
Build 6A1052d

=== Xamarin.Android ===

Version: 4.18.1 (Enterprise Edition)
Android SDK: /Users/Rob/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-466.1-11M4716)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-466.1, mixed mode)

=== Xamarin.iOS ===

Version: 8.4.0.16 (Enterprise Edition)
Hash: 80e9ff7
Branch: 
Build date: 2014-10-22 15:09:12-0400

=== Xamarin.Mac ===

Version:

=== Build Information ===

Release ID: 505030006
Git revision: fbe3e9453daf6a3bb9a9709ed22bec35f7c9056b
Build date: 2014-10-23 13:08:38-04
Xamarin addins: e44add2b39de4dd57c0742bb2e620dfad84c64c6

=== Operating System ===

Mac OS X 10.10.0
Darwin Robs-MacBook-Pro.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 1 Parmendra Kumar 2014-12-19 07:53:14 UTC
I have checked this issue but I am not able to reproduce this issue. Please check the screencast and let we know if I have missed anything. Could you Please provide us sample project that can be helpful to reproduce at my end.

Screencast: http://www.screencast.com/t/H6QMKiJhK

Environment info:

Xamarin Studio 5.5.4 (build 15)
Xamarin.Android : 4.20.0.28 (Business Edition)
Xcode 6.1 (6602)
Xamarin.iOS : 8.4.0.47 (Business Edition)
Xamarin.Mac : 1.10.0.18 (Business Edition)
Mac OS X 10.9.4
Comment 2 Jason Smith [MSFT] 2016-03-25 18:31:21 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we no longer believe it affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team