Bug 24652 - App crash using Thread Pool on Nexus 9
Summary: App crash using Thread Pool on Nexus 9
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: 5.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2014-11-19 09:18 UTC by Tracy
Modified: 2017-08-23 21:31 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Tracy 2014-11-19 09:18:28 UTC
While using the new Nexus 9 with Android 5.0 in debug mode when we run this line it randomly causes an app crash.
We can set break points inside the ValidateUser function, but when it crashes it never reaches them.
We have tried putting a try/catch inside the delegat and arround the ThreadPool call, but cannot catch an error.
Maybe this has something to do with Android 5.0 or the 64bit processor in the Nexus 9.
Also when deploying in release mode the application sometimes will not open and all and you have to click the app icon multiple times before it will open. (The login page load has no service calls and only loads the layout).


ThreadPool.QueueUserWorkItem(delegate { ValidateUser(sUserName, sPassword); });
Comment 1 Atin 2015-07-08 13:10:05 UTC
I have tried this issue but unable to reproduce the reported issue at my end.

Steps To Reproduce:
1. Create an Android application.
2. Copy the above code and used it in MainActivity.cs
3. Run the application on Device Nexus 9.

Could you please attach the sample along with the bug so that I can reproduce this issue at my end.Also provide me Application output,adb logcat,Ide log and environment info.

For VS:

Environment Info via Help->About Microsoft visual studio. 
IDE log via Help->Xamarin->Zip Xamarin Logs.

For XS:

Environment Info via Help->About->Show Details.
IDE Log via Help->Open Log Directory.

Environment Info:

=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: 9964a087-9af9-4da0-aa20-07ca4b85f306
Runtime:
	Microsoft .NET 4.0.30319.0
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

=== Xamarin.Android ===

Version: 5.1.4 (Business Edition)
Android SDK: D:\android-sdk
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: C:\Program Files (x86)\Java\jdk1.7.0_71
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) Client VM (build 24.71-b01, mixed mode, sharing)

=== Xamarin Android Player ===

Version: 0.3.7.2
Location: C:\Program Files\Xamarin Android Player\DeviceManager.exe

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 17:16:25-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Windows 6.1.7601.65536 (64-bit)
Comment 2 Cody Beyer (MSFT) 2017-08-23 21:31:27 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Android. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.