Bug 24621 - iOS: Slider don not work anymore with pre-1
Summary: iOS: Slider don not work anymore with pre-1
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-11-18 12:12 UTC by Fredy Wenger
Modified: 2014-12-19 04:24 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
detail description (2.60 MB, application/pdf)
2014-11-18 12:12 UTC, Fredy Wenger
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Fredy Wenger 2014-11-18 12:12:08 UTC
Created attachment 8789 [details]
detail description

I have sent a mail with a dropbox download-link to bugzilla@xamarin.com today (11.18).
The name of the app is MatrixGuide.
I will now upload various bug-description's related to the app (you should be able to comprehend, if you install the app).
Each .pdf also contains a short description, how to serve the app and detailed information's to my SW-versions.
Details see .pdf in the attachment

This is a "killer" for me
Comment 1 Tim Brand 2014-11-20 14:15:01 UTC
I can confirm this in iOS.

When changing the slider the following error appears:
SetValue: Can not convert 0.6703125 to type 'System.Double'

The slider isn't binded or whatever. It's just a slider in a StackLayout in a ContentPage.

You could check test my code/app on: https://github.com/App-Artment/xamarin-forms-tests
When running the app, you can find the Slider test under the 'Controls'.
Comment 2 Fredy Wenger 2014-11-21 12:27:58 UTC
Hi Tim
Your right, that the slider isn't bound ("bug" from me -> shame on me -> sorry).
But I cant comprehend your sentence...
For me, it seems as the Slider.ValueChanged-event simply does not fire anymore in iOS (where it fires on Android and WP).

But... actually I have problems with my debugger in iOS...
So maybe my debugger has a tilt, that he don't stop in the Slider.ValueChanged-event... :-()
Comment 3 Fredy Wenger 2014-11-21 12:40:21 UTC
Update: it really seems as Slider.ValueChanged-event don't fire anymore in iOS..
I have tried now in WP. I WP the slider works and also the debugger stops!
Comment 4 Udham Singh 2014-11-21 13:37:06 UTC
I have checked this issue with the help of instructions and sample app provided in comment 1, and observed that when we drag the slider we are getting the following message in output window:

2014-11-21 23:55:31.764 XamarinFormsTestsiOS[13381:288156] SetValue: Can not convert 0.159375 to type 'System.Double'
[0:] SetValue: Can not convert 0.159375 to type 'System.Double'

Screencast : http://www.screencast.com/t/OxLvVSt9Q

Debug Log : https://gist.github.com/Udham1/5dc7ec2fa51ca0c872bb
Mac Server Log : https://gist.github.com/Udham1/cb0c078b0686c0123a18

Environment Info :

Xamarin.Forms 1.3.0

Windows 8
VS 2013
Xamarin   3.8.150.0 (10cfd178d55287f09c85f5a1e604dfe20889a40f)
Xamarin.iOS Build Host : 8.4.0.43