Bug 24506 - Xamarin Forms Not Rendering Image in WP
Summary: Xamarin Forms Not Rendering Image in WP
Status: RESOLVED ANSWERED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-11-13 17:36 UTC by Steven Yi
Modified: 2015-06-02 12:25 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
This screenshot shows how the UI should be rendered. Note the icons next to "GPS Location" and "Address". (256.47 KB, image/png)
2014-11-13 17:37 UTC, Steven Yi
Details
WP screenshot. Notice the images are not showing up. (125.29 KB, image/png)
2014-11-13 17:38 UTC, Steven Yi
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Steven Yi 2014-11-13 17:36:47 UTC
Xamarin Forms sample code I wrote and demo'd a few months ago is not working correctly in latest stable release.

Images next to "GPS Location" and "Address" label fields used to display on all 3 platforms.  Same images are not showing up on Windows Phone.  The sample code is available in the Github repo below.

UI was defined in C#.  Have not tried re-attempting creating UI in XAML.

Github Repo:
https://github.com/stevenyix/Sample---Xamarin-Forms-Dependency-Service
Comment 1 Steven Yi 2014-11-13 17:37:31 UTC
Created attachment 8723 [details]
This screenshot shows how the UI should be rendered.  Note the icons next to "GPS Location" and "Address".
Comment 2 Steven Yi 2014-11-13 17:38:02 UTC
Created attachment 8724 [details]
WP screenshot.  Notice the images are not showing up.
Comment 3 Abhishek 2015-05-06 14:11:50 UTC
I have tried this issue and able to reproduce the reported behavior at my end.

Steps To Reproduce:
1.Download the sample from the given link.
2.Update the packages.
3.Run the application on WP Emulator.
4.Image next to GPS Location and Address is not showing.

screencast: http://www.screencast.com/t/FhzBa56evEk
IDE Log: https://gist.github.com/RamChBachkheti/06b2e178de48791c35be
Application Output:https://gist.github.com/RamChBachkheti/9ca2852da92315c57b53

Environment info:

Xamarin.Forms:1.4.3.6358-pre2

Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.51641
 
Xamarin   3.11.507.0 (dfac85e)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.
 
Xamarin.Android   5.1.0.127 (cbdf025e886eacb95ce7adf53346961156fae990)
Visual Studio plugin to enable development for Xamarin.Android.
 
Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.
 
Xamarin.iOS   8.10.0.0 (7741cc495ab0baf04ff0405d0604bc27f0ecae2e)
Visual Studio extension to enable development for Xamarin.iOS.
 
Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified
 
Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration
Comment 4 Rui Marinho 2015-06-02 12:25:07 UTC
Hi, you have to set your images Build Action to be Content.  Then the images will render ok.