Bug 24505 - UICatalog crashes in "Search Bar Embedded in Navigation Bar" view
Summary: UICatalog crashes in "Search Bar Embedded in Navigation Bar" view
Status: RESOLVED DUPLICATE of bug 24507
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples ()
Version: XI 8.4.0
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-11-13 16:45 UTC by Christopher Blackman
Modified: 2014-11-21 12:06 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 24507

Description Christopher Blackman 2014-11-13 16:45:57 UTC
The iOS 8 sample UICatalog crashes in the "Search Bar Embedded in Navigation Bar" view, when you click on the search bar at the top of the page the app crashes with a Foundation.MonoTouchException.

Steps to reproduce
====================

1. Open the UICatalog iOS 8 sample in Xamarin Studio, build and deploy to a device.

2. Press the back button "UICatalog" at the top left of the screen to go the controls list.

3. Scroll down until you see the list item "Search" and tap on it to enter the search section.

4. In the search section on "Search Bar Embedded in Navigation Bar"

5. After the search bar loads at the top of the screen, tap on it and the app should crash.

Here's the exception
====================

Objective-C exception thrown.  Name: NSInvalidArgumentException Reason: -[UIKit_UISearchController___Xamarin_UISearchResultsUpdating updateSearchResultsForSearchController:]: unrecognized selector sent to instance 0x17ed3aa0

Environment info:
====================

=== Xamarin Studio ===

Version 5.7 (build 441)
Installation UUID: 560ac8c1-3b61-43c9-9153-d18fe3a51e9a
Runtime:
	Mono 3.10.0 ((detached/c4d7214)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000029

=== Apple Developer Tools ===

Xcode 6.0 (6299)
Build 6A313

=== Xamarin.iOS ===

Version: 8.4.0.39 (Business Edition)
Hash: 6d89cd3
Branch: 
Build date: 2014-11-11 21:25:46-0500

=== Xamarin.Android ===

Version: 4.17.0.10 (Business Edition)
Android SDK: /Users/Chris/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3  (API level 15)
		4.4.87 (API level 20)
Java SDK: /usr
java version "1.7.0_60"
Java(TM) SE Runtime Environment (build 1.7.0_60-b19)
Java HotSpot(TM) 64-Bit Server VM (build 24.60-b09, mixed mode)

=== Xamarin.Mac ===

Not Installed

=== Build Information ===

Release ID: 507000441
Git revision: 327273fc1c6e3d70defe261ec236dd4665442119
Build date: 2014-11-10 13:04:11-05
Xamarin addins: 1f4e96a5a6e6a76e4e2cdc58b8015b2d0d8cdece

=== Operating System ===

Mac OS X 10.9.5
Darwin miguelwin7.bos.xamarin.com 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 1 Christopher Blackman 2014-11-13 16:48:32 UTC
One thing I forgot to mention, this only happens on devices, it appears to be working on the simulator.
Comment 2 Christopher Blackman 2014-11-13 17:54:52 UTC
I've tested with monotouch 8.5.0.176, and the search now works correctly on 64-bit devices. 

However now the app doesn't launch at all on 32-bit devices (https://bugzilla.xamarin.com/show_bug.cgi?id=24507).
Comment 3 Rolf Bjarne Kvinge [MSFT] 2014-11-17 05:42:23 UTC
Can you check again now that bug #24507 has been fixed?
Comment 4 Christopher Blackman 2014-11-17 16:32:19 UTC
Hi Rolfe, that bug has been fixed.
Comment 5 Rolf Bjarne Kvinge [MSFT] 2014-11-18 03:25:55 UTC
Closing then. Thanks.

*** This bug has been marked as a duplicate of bug 24507 ***
Comment 6 Christopher Blackman 2014-11-18 10:37:44 UTC
Hey Rolfe, bug #24507 has been fixed, but this particular bug is still happening on the latest build of Xamarin.iOS 8.4 (8.4.0.44). Should we leave it since it works correctly on 8.5?
Comment 8 Christopher Blackman 2014-11-21 12:06:52 UTC
Gotcha