Bug 24181 - Linker stripping inner classes despite linker.xml to the contrary
Summary: Linker stripping inner classes despite linker.xml to the contrary
Status: NEW
Alias: None
Product: Tools
Classification: Mono
Component: other ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-10-30 20:32 UTC by Kent
Modified: 2017-08-31 15:20 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
A repro for the issue. (7.46 KB, application/zip)
2014-10-30 20:32 UTC, Kent
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 24181 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Kent 2014-10-30 20:32:25 UTC
Per the attached sample, the linker is stripping both public and private inner classes even though my linker.xml is configured to include the entire assembly:

<?xml version="1.0" encoding="UTF-8" ?>

<linker>
    <assembly fullname="LinkerRepro">
        <type fullname="*"/>
    </assembly>
</linker>

My actual scenario is that I have a private inner class used reflectively my a SQLite ORM. Since the setters are accessed only via reflection, they are being stripped out by the linker.
Comment 1 Kent 2014-10-30 20:32:52 UTC
Created attachment 8570 [details]
A repro for the issue.
Comment 2 Kent 2014-10-30 20:33:45 UTC
Am using latest alpha bits, btw:

=== Xamarin Studio ===

Version 5.6.2 (build 5)
Installation UUID: f9522136-a8cf-42ce-9c1a-403970fc60e9
Runtime:
	Mono 3.10.0 ((detached/633e444)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000020

=== Xamarin.Android ===

Version: 4.99.0 (Indie Edition)
Android SDK: /Users/kent/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
Java SDK: /usr
No Java runtime present, requesting install.

=== Apple Developer Tools ===

Xcode 6.1 (6604)
Build 6A1052d

=== Xamarin.iOS ===

Version: 8.2.0.193 (Indie Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Xamarin.Mac ===

Version:

=== Build Information ===

Release ID: 506020005
Git revision: 19bc3b64b70332bfab18faf9cf1ce7d3aa191b36
Build date: 2014-10-17 14:49:01-04

=== Operating System ===

Mac OS X 10.10.0
Darwin Krang.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64