Bug 2418 - nursery pinning performance regression
Summary: nursery pinning performance regression
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: GC ()
Version: unspecified
Hardware: PC Mac OS
: --- minor
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-12-08 09:59 UTC by Rodrigo Kumpera
Modified: 2011-12-16 09:04 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rodrigo Kumpera 2011-12-08 09:59:21 UTC
Our nursery pinning code is not work as expected.

In particular, scan_starts is not working at all and for some reason.
Comment 1 Rodrigo Kumpera 2011-12-08 11:32:19 UTC
To reproduce it, try any workload and monitor that most slots in scan_starts are not filled. In the end this causes us to scan quite a lot more than needed.
Comment 2 Rodrigo Kumpera 2011-12-16 09:04:57 UTC
Fixed on trunk, now we perform as we expect to.