Bug 24175 - Unable to scroll ListView when nested in StackLayout
Summary: Unable to scroll ListView when nested in StackLayout
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.3
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-10-30 17:20 UTC by Borislav Parvanov
Modified: 2014-10-31 10:14 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Borislav Parvanov 2014-10-30 17:20:34 UTC
using System;
using Xamarin.Forms;
using System.Collections.Generic;
using System.Collections.ObjectModel;

namespace TestXamForms
{
	public class MainPage : ContentPage
	{
		ObservableCollection<string> items = new ObservableCollection<string>() { "1", "2", "3" };

		public MainPage ()
		{
			ListView listView = new ListView {
				ItemsSource = items
			};
			#if true // <-- set to false to see the correct behaviour
			// code block #1
			var content = new StackLayout {
				Spacing = 0,
				BackgroundColor = Color.Red,
				Orientation = StackOrientation.Vertical,
				Children = {
					new Grid {
						BackgroundColor = Color.Green,
						HeightRequest = 192, // <-- change this value to smaller number and observe how the scrolling behaviour changes
					},
					new Grid {
						VerticalOptions = LayoutOptions.FillAndExpand,
						RowDefinitions = { new RowDefinition { Height = new GridLength (1, GridUnitType.Star) } },
						ColumnDefinitions = { new ColumnDefinition { Width = new GridLength (1, GridUnitType.Star) } },
						Children = {
							listView
						}
					}
				}
			};
			#else 
			// code block #2
			var content = new Grid {
				RowSpacing = 0,
				BackgroundColor = Color.Red,
				RowDefinitions = { 
					new RowDefinition { Height = 192 },
					new RowDefinition { Height = new GridLength (1, GridUnitType.Star) },
				},
				Children = {
					new Grid {
						BackgroundColor = Color.Green,
					},
					new Grid {
						RowDefinitions = { new RowDefinition { Height = new GridLength (1, GridUnitType.Star) } },
						ColumnDefinitions = { new ColumnDefinition { Width = new GridLength (1, GridUnitType.Star) } },
						Children = {
							listView
						}
					}
				}
			};
			Grid.SetRow (content.Children[1], 1);
			#endif

			Content = content;
			var toolbarItem = new ToolbarItem ("Add item", null, () => {
				var item = (items.Count + 1).ToString();
				items.Add (item);
				Title = item;
				System.Diagnostics.Debug.WriteLine (listView.Bounds.ToString());
			});

			this.ToolbarItems.Add (toolbarItem);
		}
	}

	public class App
	{
		public static Page GetMainPage ()
		{	
			var mainPage = new NavigationPage (new MainPage());

			return mainPage;
		}
	}
}


To observe the bug add some items using the button in navigation bar and try to scroll the listview.
Notice that the bug is not present if you use [code block #2].
Comment 1 Shruti 2014-10-31 05:27:03 UTC
I have checked this issue by creating sample with code mentioned in comment(0). I checked both sections 'code block #1 and code block #2'. I did not see any difference during running this code on simulator. In both code block(s), I am able to scroll listview. 

Screencast regarding same : http://screencast.com/t/1XoFat6T2

Environment Info :
=== Xamarin Studio ===

Version 5.5.3 (build 6)
Installation UUID: 67eaf3b4-f8a7-4ab4-a9df-3197350ca5dc
Runtime:
	Mono 3.10.0 ((detached/fe854ad)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000025

=== Xamarin.Android ===

Version: 4.18.1 (Business Edition)
Android SDK: /Users/ixamarin78/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.iOS ===

Version: 8.4.0.15 (Business Edition)
Hash: 08968c4
Branch: 
Build date: 2014-10-20 21:48:06-0400

=== Xamarin.Mac ===

Version: 1.11.1.3 (Business Edition)

=== Build Information ===

Release ID: 505030006
Git revision: fbe3e9453daf6a3bb9a9709ed22bec35f7c9056b
Build date: 2014-10-23 13:08:38-04
Xamarin addins: e44add2b39de4dd57c0742bb2e620dfad84c64c6

=== Operating System ===

Mac OS X 10.9.4
Darwin XamnewiMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64

Please let me know If I missed anything to reproduce this issue.
Comment 2 Borislav Parvanov 2014-10-31 07:28:25 UTC
1. Make the items in the listview to be 8 by adding more using the "Add item" button.
2. Try to scroll down to see the last item

Result: You can't. 

Try the same using code block #2.
Result: You can.
Comment 3 Borislav Parvanov 2014-10-31 07:47:07 UTC
Hey I just updated to Xamarin.Forms v.1.2.3.6257 and the bug seems to be fixed. 
My previous version was 1.2.3.something_less_than_6257 and the bug was there.

You can close this bug report.
Comment 4 Shruti 2014-10-31 10:14:05 UTC
Thanks Borisiav for Checking.  This issue has been fixed. Hence, As per comment(1) and Comment(3), I am closing this issue.