Bug 24156 - Register attribute – Method usage
Summary: Register attribute – Method usage
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 8.0.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-10-30 10:17 UTC by Rustam Zaitov
Modified: 2014-11-11 21:58 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rustam Zaitov 2014-10-30 10:17:45 UTC
Now I can apply [Register] attribute to method. Looks like we haven't any use case for this.
If you apply Register instead Export (by accident) you will spend lots of time during debugging this issue.
Comment 1 Ram Chandra 2014-11-04 12:50:52 UTC
I have checked this issue but unable to reproduce this behavior.

Could you please provide steps to reproduce this issue? So that we can reproduce this issue at our end.
Comment 2 Sebastien Pouliot 2014-11-11 21:58:32 UTC
Fixed in master / d924771fce891ef44971f0ca0c58e9332a49785c

@Ram this means you won't be able to use the [Register] attribute on a method anymore (for unified only). It's not useful and can be confused with an [Export].