Bug 24121 - XI9008: Building from the command-line requires a Business license." error when building in Xamarin Studio with an Indie license
Summary: XI9008: Building from the command-line requires a Business license." error wh...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2014-10-29 00:46 UTC by PJ
Modified: 2014-10-29 17:43 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description PJ 2014-10-29 00:46:40 UTC
This bug tracks an issue reported in bug 23258, comment 2.

The bug describes getting a "XI9008: Building from the command-line requires a Business license." error when building from Xamarin Studio. 

"I just started running into this in Xamarin iOS after updating to the latest
upgrade today. Simulator builds are working but not device builds. I'm running
Xamarin iOS Indie on Yosemite."


Possible duplicate of bug 24011 (private).
Comment 1 PJ 2014-10-29 00:47:19 UTC
Hi technicat,

Sorry to hear this is happening. Can you provide the full version information from Xamarin Studio -> About Xamarin Studio, as well as the log files (Help -> Open Log Directory)? That will be useful in helping us track down the issue.

Worth noting, there is an open issue that is currently private that reports this error occurring on Yosemite after an update is installed, but is resolved with a restart of Xamarin Studio. If you haven't yet, please try restarting Xamarin Studio.
Comment 2 xamarin 2014-10-29 01:04:40 UTC
Thanks, I just restarted Xamarin Studio and it seems OK, now.

The version of Xamarin Studio is 5.5.3 build 6 running on OSX 10.10

Another thing, when I bring up About Xamarin Studio, it always brings up, on top of the About dialog, a popup saying "To view this web content, you need to install the Java Runtime Environment."

I noticed that for the first time just now, but I recently upgraded to Yosemite, so I don't know if it's due to that change or the Xamarin update.
Comment 3 Jeffrey Stedfast 2014-10-29 09:32:43 UTC
When I upgraded to Yosemite, I got the same error opening Safari on some web pages. It seems to be a Yosemite thing. Installing the JRE fixed it for me.

Google for Apple's Java Runtime Environment installer for May 2014, the ones from Oracle didn't seem to work for me.
Comment 4 Jeffrey Stedfast 2014-10-29 17:43:34 UTC
Fixed in git master