Bug 23998 - The Unified API templates do not create Unified API project types
Summary: The Unified API templates do not create Unified API project types
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.7
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-10-22 16:27 UTC by John Miller [MSFT]
Modified: 2016-12-22 19:39 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Miller [MSFT] 2014-10-22 16:27:44 UTC
**Overview:**

   Creating a Unified API project from the template does not create a Unified API project.

**Steps to Reproduce:**

   1. File -> New Project -> iOS Single View App

**Actual Results:**

   Project is created, but the project is not using the unified Xamarin.iOS assembly or have the correct project type.

**Expected Results:**

   Unified API project.

**Build Date & Platform:**

   XVS 3.7.230
Comment 1 Saurabh 2014-10-27 08:35:09 UTC
I have checked this Issue with following builds and observed that Xamarin.iOS assembly appears for Unified Single View project. This is the screencast for the same: http://www.screencast.com/t/zPdcA38o8

Checked with:
Windows 8.1
VS 2013
XVS 3.7.230

@John, Could you please let me know that machine details so that I can also reproduce it at my end?
Comment 2 Emanuel 2016-12-22 19:39:37 UTC
This issue is working fine with latest stable bits.