Bug 2387 - Cannot create a new project
Summary: Cannot create a new project
Status: CLOSED NOT_ON_ROADMAP
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: Trunk
Hardware: PC Mac OS
: Highest blocker
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-12-07 09:20 UTC by Alan McGovern
Modified: 2012-01-03 11:48 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED NOT_ON_ROADMAP

Description Alan McGovern 2011-12-07 09:20:55 UTC
System.ArgumentNullException: Argument cannot be null.
Parameter name: path1
  at System.IO.Path.Combine (System.String path1, System.String path2) [0x000c6] in /private/tmp/monobuild/build/BUILD/mono-2.10.7/mcs/class/corlib/System.IO/Path.cs:126 
  at MonoDevelop.Core.FilePath.Combine (System.String[] paths) [0x00014] in /Users/alanmcgovern/Projects/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core/FilePath.cs:150 
  at MonoDevelop.Projects.ProjectCreateInformation.get_BinPath () [0x00000] in /Users/alanmcgovern/Projects/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/ProjectCreateInformation.cs:50 
  at MonoDevelop.Projects.DotNetProject..ctor (System.String languageName, MonoDevelop.Projects.ProjectCreateInformation projectCreateInfo, System.Xml.XmlElement projectOptions) [0x00217] in /Users/alanmcgovern/Projects/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/DotNetProject.cs:143 
  at MonoDevelop.IPhone.IPhoneProject..ctor (System.String languageName, MonoDevelop.Projects.ProjectCreateInformation info, System.Xml.XmlElement projectOptions) [0x00000] in <filename unknown>:0 
  at MonoDevelop.IPhone.IPhoneProjectBinding.CreateProject (MonoDevelop.Projects.ProjectCreateInformation info, System.Xml.XmlElement projectOptions) [0x0000c] in /Users/alanmcgovern/Projects/md-addins/MonoDevelop.IPhone/MonoDevelop.IPhone/Project/IPhoneProjectBinding.cs:38 
  at MonoDevelop.Projects.ProjectService.CreateProject (System.String type, MonoDevelop.Projects.ProjectCreateInformation info, System.Xml.XmlElement projectOptions) [0x00033] in /Users/alanmcgovern/Projects/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/ProjectService.cs:498 
  at MonoDevelop.Ide.Templates.ProjectDescriptor.CreateItem (MonoDevelop.Projects.ProjectCreateInformation projectCreateInformation, System.String defaultLanguage) [0x00036] in /Users/alanmcgovern/Projects/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Templates/ProjectDescriptor.cs:111 
  at MonoDevelop.Ide.Templates.ProjectTemplate.HasItemFeatures (MonoDevelop.Projects.SolutionFolder parentFolder, MonoDevelop.Projects.ProjectCreateInformation cinfo) [0x0000e] in /Users/alanmcgovern/Projects/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Templates/ProjectTemplate.cs:302 
  at MonoDevelop.Ide.Projects.NewProjectDialog.SelectedIndexChange (System.Object sender, System.EventArgs e) [0x00107] in /Users/alanmcgovern/Projects/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Projects/NewProjectDialog.cs:480
Comment 1 Alan McGovern 2011-12-08 11:20:15 UTC
I think this issue was caused by a bad build after the stetic addin nuked part of a gui.stetic file.
Comment 2 Atin 2011-12-29 00:56:08 UTC
We are able to create a new project, please close this issue.

Environments:
MAC 10.7
Mono Develop 2.8.5 Stable.
Mono Touch 5.0.4 Stable
Mono Framework 2.0.7 Beta
Comment 3 Alan McGovern 2011-12-29 09:28:35 UTC
This was more than likely due to stetic breaking things as I haven't been able to reproduce the issue since I cleaned and rebuilt.