Bug 23722 - XIB files not compiled after iOS target switch
Summary: XIB files not compiled after iOS target switch
Status: CLOSED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: XI 8.0.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2014-10-09 15:52 UTC by Sebastian Krawczuk
Modified: 2015-02-26 06:25 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description Sebastian Krawczuk 2014-10-09 15:52:48 UTC
After I switch the build target from iOS Simulator to iOS Device none of XIB files are compiled to NIB files at _CoreCompileInterfaceDefinitions which causes _CopyContentToBundle to fail to copy NIB files to the application bundle with error:

"
Build FAILED.
Errors:

/Volumes/LaCie/Xamarin/Sample Apps/MISandboxTestMonoSolution/MISandboxTestMono.iOS/MISandboxTestMono.iOS.csproj (Build) ->
/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets (_CopyContentToBundle target) ->

	/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: error : Cannot copy /Volumes/LaCie/Xamarin/Sample Apps/MISandboxTestMonoSolution/MISandboxTestMono.iOS/obj/iPhone/Debug/ibtool/PrintUIDocumentInteractionControllerTest.nib to /Volumes/LaCie/Xamarin/Sample Apps/MISandboxTestMonoSolution/MISandboxTestMono.iOS/bin/iPhone/Debug/MISandboxTestMonoiOS.app/PrintUIDocumentInteractionControllerTest.nib, as the source file doesn't exist.
	/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: error : Cannot copy /Volumes/LaCie/Xamarin/Sample Apps/MISandboxTestMonoSolution/MISandboxTestMono.iOS/obj/iPhone/Debug/ibtool/PrintUIPrintInteractionControllerTest.nib to /Volumes/LaCie/Xamarin/Sample Apps/MISandboxTestMonoSolution/MISandboxTestMono.iOS/bin/iPhone/Debug/MISandboxTestMonoiOS.app/PrintUIPrintInteractionControllerTest.nib, as the source file doesn't exist.
	/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: error : Cannot copy /Volumes/LaCie/Xamarin/Sample Apps/MISandboxTestMonoSolution/MISandboxTestMono.iOS/obj/iPhone/Debug/ibtool/PasteboardQLPreviewControllerTest.nib to /Volumes/LaCie/Xamarin/Sample Apps/MISandboxTestMonoSolution/MISandboxTestMono.iOS/bin/iPhone/Debug/MISandboxTestMonoiOS.app/PasteboardQLPreviewControllerTest.nib, as the source file doesn't exist.
"

To workaround it I have to clean the iOS project and build it again for the new target.

Worth to note that all my XIB files in the iOS project are cross-project "soft links" to existing Xcode project.
Comment 1 Ram Chandra 2014-10-16 09:34:29 UTC
I have tried issue but I am unable to reproduce this, we may have to see if a developer can figure out what's going on from the error logs. If you have a chance, it might also be helpful to include sample project, build output and build information. 

You can get build information from here:

Xamarin Studio => About Xamarin Studio => Show Details => Copy Information.

Also, I am not sure about final line of the bug i.e.

> Worth to note that all my XIB files in the iOS project are cross-project "soft links" to existing Xcode >project.

Could you please clarify this?
Comment 2 Sebastian Krawczuk 2015-02-25 16:22:21 UTC
I cannot reproduce this anymore with latest Xamarin Studio. Seems like it got fixed.

Thanks for looking into this.
Comment 3 Sebastian Krawczuk 2015-02-25 16:24:40 UTC
It must have been fixed in recent IDE/toolchain.
Comment 4 Ram Chandra 2015-02-26 06:25:18 UTC
As per Comment 2 and Comment 3 this issue is not exist. Hence I am closing this issue.