Bug 23719 - MasterDetailPage does not show Master page title in Navigation bar when app is started in landscape and rotated to portrait
Summary: MasterDetailPage does not show Master page title in Navigation bar when app i...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.3
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL: https://github.com/xamarin/Duplo/issu...
Depends on:
Blocks:
 
Reported: 2014-10-09 14:47 UTC by Jon Goldberger [MSFT]
Modified: 2016-03-18 08:24 UTC (History)
4 users (show)

Tags: AC
Is this bug a regression?: ---
Last known good build:


Attachments
Test Project (26.99 KB, application/zip)
2014-10-09 14:47 UTC, Jon Goldberger [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jon Goldberger [MSFT] 2014-10-09 14:47:35 UTC
Created attachment 8368 [details]
Test Project

## Description

When launching a Forms app with a MasterDetailPage to an iPad in Landscape, the Master page is shown as expected without a Navigation item in the Navigation bar, as expected. When you rotate to portrait the Master page is hidden as expected but the Navigation item to open the Master page is still not shown so the only way to open the Master page is with a swipe. When launching in Portrait the Navigation item that opens the Master page is shown, but is still shown when rotated to Landscape even though it is now not necessary as the Master page is open in landscape mode. 

## Steps to reproduce

1. Open attached test project and restore packages.
2. Set the iOS project as the startup project and launch to an iPad simulator (I used an iPad Retina 8.0 simulator).
3. Rotate the device to landscape

Expected result: The Navigation item "Master Page" will disappear in Landscape.
Actual result: The Navigation item "Master Page" is still visible. 

4. Stop debugging and relaunch to the iPad in Landscape orientation. 
5. Note that there is no Navigation item "Master Page" as expected.
6. Rotate device to Portrait.

Expected result: The Navigation item "Master Page" will appear in Portrait.
Actual result: The Navigation item "Master Page" is not visible in Portrait. 

## Notes

In native iOS apps using a SplitViewController, I do know that you have to manually handle adding and removing the Navigation item on rotation so I suspect this is not being done by forms.
Comment 1 Parmendra Kumar 2014-10-13 04:29:07 UTC
I have checked this issue, And I am able to reproduce this To reproduce this issue I have followed steps defined in the bug description.

Screencast:http://www.screencast.com/t/WoEiypNSKoug
IDE Log:https://gist.github.com/Parmendrak/48a0009d74889dcf44bc
OutputLog:https://gist.github.com/Parmendrak/fc8a7df49b708de6d583

Environment Info:
=== Xamarin Studio ===

Version 5.5 (build 227)
Installation UUID: 1a096c6f-0678-402e-89b2-a2c10f7e80e4
Runtime:
	Mono 3.10.0 ((detached/47db868)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000019

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.iOS ===

Version: 8.2.0.193 (Business Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Xamarin.Android ===

Version: 4.18.0 (Business Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.Mac ===

Version: 1.10.0.13 (Business Edition)

=== Build Information ===

Release ID: 505000227
Git revision: 7b721eeec7a2fa4c4f4de0ecd2aed4dc25edac95
Build date: 2014-10-02 15:53:38-04
Xamarin addins: 99ed56b428b31eba1efaace4d82188d6f334e6ca

=== Operating System ===

Mac OS X 10.9.4
Darwin ShrutiMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 2 Jason Smith [MSFT] 2016-03-18 08:24:12 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we no longer believe it affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team