Bug 23655 - MFMailComposeViewController AutoCorrect Duplicates First Letter
Summary: MFMailComposeViewController AutoCorrect Duplicates First Letter
Status: RESOLVED UPSTREAM
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 8.2.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-10-06 16:16 UTC by Cody Beyer (MSFT)
Modified: 2015-12-16 17:14 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
TestCase (12.25 KB, application/zip)
2014-10-06 16:17 UTC, Cody Beyer (MSFT)
Details
Xcode example: also fails (45.63 KB, application/zip)
2014-10-08 14:30 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description Cody Beyer (MSFT) 2014-10-06 16:16:25 UTC
When editing the body of the email in the attached testcase, autocorrecting a misspelled word will duplicate the first letter of said word

Steps to Reproduce:
Open TestCase in Xamarin Studio
Deploy to iOS 7 Device
Click the Click Me button
Type a word that is misspelled 
Allow autocorrect to fix it
Notice the first letter duplicated 

Thank you.
Comment 1 Cody Beyer (MSFT) 2014-10-06 16:17:52 UTC
Created attachment 8323 [details]
TestCase
Comment 2 Rajneesh Kumar 2014-10-07 03:45:20 UTC
I have checked this issue and able to reproduce. To reproduce this issue I have followed the steps mentioned in bug description.

Steps I have followed:

1. Open attached sample application in XS
2. Build the application and deploy it on simulator
3. It will deploy successfully, click the "Click Me" button
4. A compose mail page will show
5. Edit the body of the mail and type a word that is misspelled
6. Allow autocorrect to fix it
7. Observe that the first letter is duplicated of the word

Additional Information: Getting same behavior on device and simulator.

Screencast:  http://www.screencast.com/t/wIiaAj663A

Environment info:

=== Xamarin Studio ===

Version 5.5 (build 227)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
Runtime:
	Mono 3.10.0 ((detached/47db868)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000019

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.Mac ===

Version: 1.10.0.13 (Starter Edition)

=== Xamarin.Android ===

Version: 4.18.0 (Enterprise Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin.iOS ===

Version: 8.2.0.193 (Enterprise Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Build Information ===

Release ID: 505000227
Git revision: 7b721eeec7a2fa4c4f4de0ecd2aed4dc25edac95
Build date: 2014-10-02 15:53:38-04
Xamarin addins: 99ed56b428b31eba1efaace4d82188d6f334e6ca

=== Operating System ===

Mac OS X 10.9.5
Darwin MacMini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2014-10-08 14:30:11 UTC
Created attachment 8357 [details]
Xcode example: also fails

Here's an Objective-C sample (based on Apple's example code [1]) that shows the same problem. It simply puts the same HTML in the message body of the `MFMailComposeViewController` as in the C# sample.

There are certain items in the HTML that cause this problem. Removing those "incompatible" parts of the HTML stops the problem.

This behavior/bug is in Apple's code upstream of Xamarin.

> [1] https://developer.apple.com/library/iOS/samplecode/MessageComposer/Introduction/Intro.html#//apple_ref/doc/uid/DTS40010161
Comment 4 Rolf Bjarne Kvinge [MSFT] 2014-10-10 09:22:39 UTC
Closing since this is not a bug in any Xamarin product according to the last comment.
Comment 5 Zev Eisenberg 2015-12-15 23:04:02 UTC
Did anyone file a radar for this issue? I'm seeing the same issue on an Objective-C (non-Xamarin) project, but removing the <head> tag doesn't work like it did in https://bugzilla.xamarin.com/attachment.cgi?id=8357
Comment 6 Rolf Bjarne Kvinge [MSFT] 2015-12-16 13:46:56 UTC
@Zev, no radar was filed.
Comment 7 Zev Eisenberg 2015-12-16 17:14:00 UTC
I filed one, in case future explorers stumble across this post: http://www.openradar.me/23920816