Bug 23636 - Toolbars not working correctly on Samsung Android devices
Summary: Toolbars not working correctly on Samsung Android devices
Status: RESOLVED INVALID
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.3
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL: https://github.com/xamarin/Duplo/issu...
Depends on:
Blocks:
 
Reported: 2014-10-06 04:49 UTC by billy.leverington
Modified: 2014-12-09 06:28 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
adb logs and screen shots from 3 devices (302.11 KB, application/zip)
2014-10-06 04:49 UTC, billy.leverington
Details
Another Example (4.90 MB, application/zip)
2014-10-07 05:00 UTC, billy.leverington
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description billy.leverington 2014-10-06 04:49:30 UTC
Created attachment 8315 [details]
adb logs and screen shots from 3 devices

A toolbar setup with secondary items is not displayed correctly on a Samsung S3 or S4, but does work correctly on a HTC One.

The example used is 
https://github.com/tkowalczyk/SimpleToolbarsForms

The same is true if the toolbar is setup in xaml. 

It seems secondary items are not handled correctly on the Samsung devices.
Comment 1 Rajneesh Kumar 2014-10-06 07:17:35 UTC
I have checked this issue and and able to reproduce the behavior. I have checked it on device(s3) and emulator and getting same behavior. 

Screencast: http://www.screencast.com/t/kpfbvojoaQn

Please let me know the is this the same behavior you are experiencing, shown in the screencast ? If no then could you please provide me steps to reproduce this issue. That will be helpful to reproduce this issue at our end.

Environment Info: 

=== Xamarin Studio ===

Version 5.5 (build 227)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
Runtime:
	Mono 3.10.0 ((detached/47db868)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000019

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.Mac ===

Version: 1.10.0.18 (Starter Edition)

=== Xamarin.Android ===

Version: 4.18.0 (Enterprise Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin.iOS ===

Version: 8.2.0.193 (Enterprise Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Build Information ===

Release ID: 505000227
Git revision: 7b721eeec7a2fa4c4f4de0ecd2aed4dc25edac95
Build date: 2014-10-02 15:53:38-04
Xamarin addins: 99ed56b428b31eba1efaace4d82188d6f334e6ca

=== Operating System ===

Mac OS X 10.9.5
Darwin MacMini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 2 billy.leverington 2014-10-07 05:00:05 UTC
Created attachment 8334 [details]
Another Example
Comment 3 billy.leverington 2014-10-07 05:00:43 UTC
You said 'I have checked it on device(s3) and emulator and getting same behaviour.'

But on the screencast it is working fine, which I would expect, as this seems to be a bug related to Samsung devices only. Im assume it did not work on the S3 for you ?

I have attached another zip, with a very simple example, that just puts two items into the toolbar as 'secondary'. You can see from the screen shots I have also included, on the HTC one the menu is present as expected, but on the Samsung S4, nothing is displayed.
Comment 4 Rajneesh Kumar 2014-10-07 06:21:59 UTC
As per comment 3

I have checked this issue again and able to reproduce this. To reproduce this issue I have followed the sample application and instruction provided in comment 3.

Steps I have followed:

1. Ope attached sample application in Xs
2. Set Android as start up project, and build it
3. Deploy the application on HTC
4. Observed that on the HTC one the menu is present as expected
5. Deploy it on s4 and observe that nothing is displayed

Screenshot:  http://www.screencast.com/t/ZVGlvpLc

Environment Info: 

=== Xamarin Studio ===

Version 5.5 (build 227)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
Runtime:
	Mono 3.10.0 ((detached/47db868)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000019

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.Mac ===

Version: 1.10.0.13 (Starter Edition)

=== Xamarin.Android ===

Version: 4.18.0 (Enterprise Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin.iOS ===

Version: 8.2.0.193 (Enterprise Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Build Information ===

Release ID: 505000227
Git revision: 7b721eeec7a2fa4c4f4de0ecd2aed4dc25edac95
Build date: 2014-10-02 15:53:38-04
Xamarin addins: 99ed56b428b31eba1efaace4d82188d6f334e6ca

=== Operating System ===

Mac OS X 10.9.5
Darwin MacMini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 5 Jason Smith [MSFT] 2014-12-09 06:28:50 UTC
This is due to the fact that the SIII/4 use the physical menu button which causes a slide in menu to trigger. This is expected behavior on these devices.