Bug 23596 - Controls in RelativeLayout not showing when using custom page renderer unless control size is explicitly set in Forms project.
Summary: Controls in RelativeLayout not showing when using custom page renderer unless...
Status: RESOLVED INVALID
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.2
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-10-03 15:14 UTC by Jon Goldberger [MSFT]
Modified: 2016-03-18 08:17 UTC (History)
4 users (show)

Tags: AC
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Jon Goldberger [MSFT] 2014-10-03 15:14:46 UTC
## Description

In a Forms ContentPage whose content is a RelativeLayout that includes some controls, though all of the controls are rendered properly using the default page renderer, if using a custom page renderer controls that do not set the size explicitly do not render. Tested this on Forms versions 1.2.2.6243 and 1.2.3.6257.

## Steps to reproduce

1. Open the attached test project and restore packages.
2. Launch the iOS project to a simulator or device.

## Expected result

Page that shows should have two labels and a button.

## Actual result

Page only displays one label and a button.

## Further test to confirm that second label is rendered using the default page renderer

3. In the App.cs file of the Forms project, change:

return new RightSideMenuPage();

to 

return new MainPage();

4. Launch iOS app.

## Expected result

Page shows with two labels and a button.

## Actual result

As expected.


## Notes 

Look in MainPage.cs of the Forms project and note that for the second Label, only the x and y values are given. This is the Label that is not rendering using the custom page renderer, but does using the default renderer.
Comment 2 Parmendra Kumar 2014-10-04 03:08:27 UTC
I have checked this issue and I am able to reproduce it. To reproduce this issue I have followed steps mentioned in the bug description.

Screencast:http://www.screencast.com/t/j2xcjpx8
IDE Log:https://gist.github.com/anonymous/023d8944baf95afd500a
OutputLog:https://gist.github.com/anonymous/caaf2d71219c252717ac

Environment Info:
=== Xamarin Studio ===

Version 5.5 (build 227)
Installation UUID: 1a096c6f-0678-402e-89b2-a2c10f7e80e4
Runtime:
	Mono 3.8.0 ((no/db71bc1)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000013

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.iOS ===

Version: 8.2.0.193 (Business Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Xamarin.Android ===

Version: 4.18.0 (Business Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.Mac ===

Version: 1.10.0.13 (Business Edition)

=== Build Information ===

Release ID: 505000227
Git revision: 7b721eeec7a2fa4c4f4de0ecd2aed4dc25edac95
Build date: 2014-10-02 15:53:38-04
Xamarin addins: 99ed56b428b31eba1efaace4d82188d6f334e6ca

=== Operating System ===

Mac OS X 10.9.4
Darwin ShrutiMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 3 Jason Smith [MSFT] 2016-03-18 08:17:33 UTC
The issue is in the custom renderer implementation