Bug 23509 - Back button not working with iOS Custom PageRenderer
Summary: Back button not working with iOS Custom PageRenderer
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.2
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL: https://github.com/xamarin/Duplo/issu...
Depends on:
Blocks:
 
Reported: 2014-09-30 18:19 UTC by Jon Goldberger [MSFT]
Modified: 2016-03-16 12:01 UTC (History)
5 users (show)

Tags: AC
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jon Goldberger [MSFT] 2014-09-30 18:19:29 UTC
Created attachment 8263 [details]
Test Project

## Bug Description

When using a PageRenderer, if a new Forms page is pushed from the custom rendered page using Navigation.PushAsync(new ContentPage()) in the Forms project, using a Forms button that is rendered on the page, the Back button does not work to go back to the original page. Adding a button to the new ContentPage (in Forms core project) that is pushed and executing Navigation.PopAsync() when that new button is clicked does return to the original page. I am not sure if this is a supported scenario. It would seem, but I do not know, that the Back button is using the iOS navigation stack which might have no knowledge of the Forms Navigation stack.

## Steps to Reproduce

1. Open the test project and restore packages.
2. Launch iOS app to the simulator.
3. Click the "show new page" button.
4. A new page will slide in.
5. Click the Back button in the Navigation bar.

## Expected result

Will return to previous page.

## Actual result

Nothing happens.

## Notes

Note that using the Forms PopAsync() button in the page itself does work to navigate back to the previous view controller.
Comment 2 Rajneesh Kumar 2014-10-01 01:36:22 UTC
I have checked this issue and able to reproduce this. To reproduce this issue I have followed the steps mentioned in the above bug description.

I observed that when Back button is clicked in the Navigation bar, nothing happens. It does't returns to the pervious page.

Screencast: http://www.screencast.com/t/t5KAbL93

Environment Info:

=== Xamarin Studio ===

Version 5.4 (build 240)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
Runtime:
	Mono 3.10.0 ((detached/53e3161)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000018

=== Xamarin.Android ===

Version: 4.16.0 (Enterprise Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.iOS ===

Version: 8.0.0.63 (Enterprise Edition)
Hash: 58b46df
Branch: 
Build date: 2014-09-18 22:32:07-0400

=== Xamarin.Mac ===

Version: 1.10.0.13 (Starter Edition)

=== Build Information ===

Release ID: 504000240
Git revision: 01786bc67c7024ec33d327ed27e4416d7a846f4e
Build date: 2014-09-17 10:58:48-04
Xamarin addins: 7cd7dfcd6b7b7b53281508954ec080f1cd153ad3

=== Operating System ===

Mac OS X 10.9.5
Darwin MacMini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 3 Jon Goldberger [MSFT] 2014-10-03 15:01:33 UTC
Likely related to: https://bugzilla.xamarin.com/show_bug.cgi?id=21932
Comment 4 Kent Green [MSFT] 2015-01-23 14:47:57 UTC
Adding Bug 26351 - [iOS] Back button not shown on Navigation Page as a possibly related "see also" link.

The main difference I noted in 26531 versus this bug is that while in this bug, the back button is shown but can't be clicked; in 26531 the back button isn't shown at all.
Comment 5 Kent Green [MSFT] 2015-01-23 14:50:14 UTC
(Minor typos in my previous comment 4, in the paragraph I switched the 3 & 5 digits around in the bug number. The link is still correct, though.)
Comment 6 Jason Smith [MSFT] 2016-03-16 12:01:38 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we no longer believe it affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team