Bug 23497 - setting MasterDetailPage.IsPresented = true does not show the Master page
Summary: setting MasterDetailPage.IsPresented = true does not show the Master page
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.3
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL: https://github.com/xamarin/Duplo/issu...
Depends on:
Blocks:
 
Reported: 2014-09-30 11:28 UTC by Greg Ferreri
Modified: 2015-02-17 11:47 UTC (History)
9 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
App.cs file of a generic Xamarin.Forms project, using a MasterDetailPage (670 bytes, application/octet-stream)
2014-09-30 11:28 UTC, Greg Ferreri
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Greg Ferreri 2014-09-30 11:28:00 UTC
Created attachment 8255 [details]
App.cs file of a generic Xamarin.Forms project, using a MasterDetailPage

Targeting iPad, setting a MasterDetailPage's IsPresented property to true does not cause the Master page to be displayed. The master page will not display unless a swipe gesture is made on the detail page. The documentation suggests that setting IsPresented to true will cause the Master to display.
Comment 1 Parmendra Kumar 2014-09-30 13:51:38 UTC
I have checked this issue with attached sample and getting an exception "Title property must be set on Master page", Could you Please check the screencast and let me know if you get same behavior or I missed anything. 

Screencast: http://www.screencast.com/t/JrFajU6ew
IDE Log:https://gist.github.com/saurabh360/f6c7a8cdc68ba3244744
Output Log: https://gist.github.com/saurabh360/22e43219f8d5924c56ce

Environment Info:
=== Xamarin Studio ===

Version 5.4 (build 240)
Installation UUID: 1a096c6f-0678-402e-89b2-a2c10f7e80e4
Runtime:
	Mono 3.8.0 ((no/db71bc1)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000013

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.Mac ===

Version: 1.10.0.13 (Business Edition)

=== Xamarin.Android ===

Version: 4.16.0 (Business Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.iOS ===

Version: 8.0.0.63 (Business Edition)
Hash: 58b46df
Branch: 
Build date: 2014-09-18 22:32:07-0400

=== Build Information ===

Release ID: 504000240
Git revision: 01786bc67c7024ec33d327ed27e4416d7a846f4e
Build date: 2014-09-17 10:58:48-04
Xamarin addins: 7cd7dfcd6b7b7b53281508954ec080f1cd153ad3

=== Operating System ===

Mac OS X 10.9.4
Darwin ShrutiMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 2 Greg Ferreri 2014-09-30 14:24:59 UTC
I was building against an older version of Xamarin.Forms. When updating my packages, I also see the exception you described. Simply giving the Title property a value will fix this, and the original issue can still be seen.

Master = new ContentPage () {
					Content = new ListView () {

						ItemsSource = numbers
					},
					Title = "Master˚",
				},
Comment 3 Parmendra Kumar 2014-10-01 08:07:49 UTC
As per the comment 2, I have checked this issue on Xamarin.Forms 1.2.2.6263 and 1.2.3.6256-pre4, I am  observed that the master page is showing. Please check the screencast and Let me know If I missed anything.

Screencast:http://www.screencast.com/t/AYIlHoQaVqi
Comment 4 Greg Ferreri 2014-10-01 09:31:17 UTC
I checked the screencast, and I see the same issue as I see when I build myself. The issue is that you must swipe to view the master page, even though IsPresented = true. The expected behavior is that the master page is shown without the need to swipe.
Comment 5 Parmendra Kumar 2014-10-01 09:43:17 UTC
As per the Comment #4 confirm this bug.

OutputLog:https://gist.github.com/saurabh360/9b858de05df9cbc1954e
IDELog:https://gist.github.com/saurabh360/1a92399b3098003b957a
Comment 6 Daniele Parisi 2015-02-17 03:52:26 UTC
The bug is already present in Xamarin.Forms.1.3.1.629

Targeting iPad, setting a MasterDetailPage's IsPresented property to true does
not cause the Master page to be displayed. iPhone and Android version of the app works well.
Comment 7 Parmendra Kumar 2015-02-17 05:26:26 UTC
I have recheck this issue with Xam.Forms 1.3.3.6323 and I observed that its working fine. Could you please recheck this issue with latest Xam.forms version and Let we know if you getting same behavior.

Screencast: http://www.screencast.com/t/jitVG3SWuCU

Environment info: 

Xamarin Studio  5.7.1 (build 17)
Xcode 6.1.1 (6611)
Xamarin.iOS : 8.6.1.20 (Business Edition)
Xamarin.Mac: 1.10.0.18 (Business Edition)
Xamarin.Android : 4.20.0.28 (Business Edition)
Operating System Mac OS X 10.9.4
Comment 8 Parmendra Kumar 2015-02-17 05:36:32 UTC
I also checked with Xamarin.Forms version 1.3.1.6296 and I am not getting issue.

Screeencast for the same: http://www.screencast.com/t/04XCH7CJReM
Comment 9 Daniele Parisi 2015-02-17 05:39:57 UTC
May be that it works fine with Xam.Forms 1.3.3.6323 ,but I cannot upgrade beacause in that version (and also in the following releases) there is an other bug.
https://bugzilla.xamarin.com/show_bug.cgi?id=26761
Comment 10 Parmendra Kumar 2015-02-17 07:48:07 UTC
Thanks Daniele

As per comment 9, the reported issue is fixed.

Hence closing this issue. 

And the bug 26761 will be fixed very soon.
Comment 11 Daniele Parisi 2015-02-17 11:47:01 UTC
Thank you Parmendra