Bug 23468 - Data intermittently fails to reappear after screen unlock
Summary: Data intermittently fails to reappear after screen unlock
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.18.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-09-29 18:01 UTC by Cody Beyer (MSFT)
Modified: 2017-06-28 19:18 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Cody Beyer (MSFT) 2014-09-29 18:01:33 UTC
A customer has reported an error with the resuming function after a device has been locked. 

To recreate the issue:

1. Run App with TextFields populated from Resources
2. Sleep device with app active
3. Resume device
3. Observe populated text fields are now blank.

I am attempting to create an example project that demonstrates the issue, as well as attempting a screencast from the customer.

Thanks
Comment 2 Sadik Ali 2014-09-30 04:50:57 UTC
I tried to reproduce this issue but I am unable to reproduce this issue.

Steps I followed:

1. Create an android application.
2. Add a edit text box in Main.axml file

 <EditText
    android:text="@string/editTextValue" 
    android:id="@+id/edittext"
    android:layout_width="fill_parent"
    android:layout_height="wrap_content"/>

3. Add the edit text values in String.xml file

   <string name="editTextValue">This is edit text field</string>

4.  Write the following code in MainActivity.cs file

      EditText eText = FindViewById<EditText>(Resource.Id.edittext);
    
     // use this code in button event handler.
     var valueOfCount=string.Format("{0} clicks!", count++);
     eText.Text= valueOfCount;

5. Build and deploy the project.

I have set the default text of edit text box from the string.xml file and when I deploy the application on device, app deployed successfully and then I press device screen lock/ sleep button and after few time(5-10 seconds) when I unlock the device, the default text is still present in text box. I have changed the value of text box at run time and follow the same steps and the new text is still available in text box. 

Note: I have deployed app on Samsung S3 device.

Please let me know if I am missing something?

Environment Info:

Mac OS X 10.9.5
Xamarin Studio: 5.5 (build 223)
Mono 3.10.0 ((detached/ac51002)
GTK+ 2.24.23 (Raleigh theme)
Package version: 310000016
Xamarin.Android : 4.18.0.32 

=== Build Information ===
Release ID: 505000223
Git revision: 7bf83889c0de1aa00290619cb8ed48acbed72c52
Build date: 2014-09-29 13:12:41-04
Xamarin addins: 257f0493a82f82ff28cf770b1ed09bd181d62968
Comment 3 Chris Hardy [MSFT] 2017-06-28 19:18:11 UTC
Unfortunately, we’re unable to reproduce this report. If this issue is still occurring for you, please reopen this issue and attach a reproduction to the bug by starting with a clean Xamarin.Android project adding just the code necessary to demonstrate the issue.