Bug 23422 - Intermittent Connectivity issues with Build Host along with "minor mismatch" error message
Summary: Intermittent Connectivity issues with Build Host along with "minor mismatch" ...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.6
Hardware: PC Mac OS
: High major
Target Milestone: 3.7
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-09-26 15:12 UTC by Dominic N [MSFT]
Modified: 2015-04-01 09:03 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 PJ 2014-09-26 15:23:15 UTC
Worth noting that the logs included in the desk case indicate that the customer was using XVS 3.5.58 and XI 7.4.0.108, although it looks like you may have some updated information that isn't in the case.

Also, the warning you listed "There is a minor mismatch..." can be ignored if that's all they're seeing.

The exceptions I found in the logs are from the iOS designer. Here is a snippet of the mtbserver log they included in the desk case:

17-Sep-2014 16:51:09] Finishing Output (log:writer) Thread...
[17-Sep-2014 16:51:09] Error: An error occurred (no details available)
[17-Sep-2014 16:51:10] Request handled in 2.948ms
[17-Sep-2014 16:51:10] Exception: Exception type: System.ObjectDisposedException
The object was used after being disposed.
  at MonoTouch.Design.Client.Mac.MacServerProcessConnection.EnsureServerRunning (Boolean throwIfNotRunning) [0x00000] in <filename unknown>:0 
  at MonoTouch.Design.Client.ServerProcessConnection.SendRequest (System.Action`1 send, System.Action`1 recv, Boolean throwIfNotRunning) [0x00000] in <filename unknown>:0 
  at MonoTouch.Design.Client.ServerProcessConnection.SendRequest (MonoTouch.Design.CommandRequest req, Boolean throwIfNotRunning) [0x00000] in <filename unknown>:0 
  at Mtb.Server.Commands.DesignerSendPayload.HandleRequest (ILoggingHelper logger, System.Object commandRequestState) [0x00000] in <filename unknown>:0 
[17-Sep-2014 16:51:10] Command [DesignerSendPayload: CommmandUrl=DesignerSendPayload] finished (20)
[17-Sep-2014 16:51:10] Request handled in 2872.653ms
[17-Sep-2014 16:51:10] Deserializing designer command: 5.656ms
[17-Sep-2014 16:51:10] Exception: Exception type: System.NullReferenceException
Object reference not set to an instance of an object
  at Mtb.Server.Commands.DesignerConnectionCommand.get_ConnectionAttributes () [0x00000] in <filename unknown>:0 
  at Mtb.Server.Commands.DesignerConnectionCommand.get_Connection () [0x00000] in <filename unknown>:0 
  at Mtb.Server.Commands.DesignerSendPayload.HandleRequest (ILoggingHelper logger, System.Object commandRequestState) [0x00000] in <filename unknown>:0 
[17-Sep-2014 16:51:10] Command [DesignerSendPayload: CommmandUrl=DesignerSendPayload] finished (21)
[17-Sep-2014 16:51:10] Handling with command: [DesignerInvalidateConnection: CommmandUrl=DesignerInvalidateConnection] (7)
[17-Sep-2014 16:51:10] Attempting to acquire command execution lock, timeout set to 00:10:00
[17-Sep-2014 16:51:10] Deserializing designer command: 2.539ms
[17-Sep-2014 16:51:10] Request handled in 2385.041ms
[17-Sep-2014 16:51:10] Exception: Exception type: System.NullReferenceException
Object reference not set to an instance of an object
  at Mtb.Server.Commands.DesignerConnectionCommand.get_ConnectionAttributes () [0x00000] in <filename unknown>:0 
  at Mtb.Server.Commands.DesignerInvalidateConnection.HandleRequest (ILoggingHelper logger, System.Object commandRequestState) [0x00000] in <filename unknown>:0 
[17-Sep-2014 16:51:10] Command [DesignerInvalidateConnection: CommmandUrl=DesignerInvalidateConnection] finished (7)
[17-Sep-2014 16:51:10] Exception: Exception type: System.NullReferenceException
Object reference not set to an instance of an object
  at Mtb.Server.Commands.DesignerConnectionCommand.get_ConnectionAttributes () [0x00000] in <filename unknown>:0 
  at Mtb.Server.Commands.DesignerConnectionCommand.get_Connection () [0x00000] in <filename unknown>:0 
  at Mtb.Server.Commands.DesignerSendPayload.HandleRequest (ILoggingHelper logger, System.Object commandRequestState) [0x00000] in <filename unknown>:0 
[17-Sep-2014 16:51:10] Request handled in 19.268ms
[17-Sep-2014 16:51:10] Command [DesignerSendPayload: CommmandUrl=DesignerSendPayload] finished (13)
[17-Sep-2014 16:51:10] Request handled in 2550.724ms
[17-Sep-2014 16:51:10] Handling with command: [DesignerInvalidateConnection: CommmandUrl=DesignerInvalidateConnection] (21)
[17-Sep-2014 16:51:10] Attempting to acquire command execution lock, timeout set to 00:10:00
[17-Sep-2014 16:51:10] Exception: Exception type: System.NullReferenceException
Object reference not set to an instance of an object
  at Mtb.Server.Commands.DesignerConnectionCommand.get_ConnectionAttributes () [0x00000] in <filename unknown>:0 
  at Mtb.Server.Commands.DesignerInvalidateConnection.HandleRequest (ILoggingHelper logger, System.Object commandRequestState) [0x00000] in <filename unknown>:0 
[17-Sep-2014 16:51:10] Command [DesignerInvalidateConnection: CommmandUrl=DesignerInvalidateConnection] finished (21)
[17-Sep-2014 16:51:10] Request handled in 8.414ms
[17-Sep-2014 16:51:10] Handling with command: [DesignerInvalidateConnection: CommmandUrl=DesignerInvalidateConnection] (13)
[17-Sep-2014 16:51:10] Attempting to acquire command execution lock, timeout set to 00:10:00
[17-Sep-2014 16:51:10] Exception: Exception type: System.NullReferenceException
Object reference not set to an instance of an object
  at Mtb.Server.Commands.DesignerConnectionCommand.get_ConnectionAttributes () [0x00000] in <filename unknown>:0 
  at Mtb.Server.Commands.DesignerInvalidateConnection.HandleRequest (ILoggingHelper logger, System.Object commandRequestState) [0x00000] in <filename unknown>:0 
[17-Sep-2014 16:51:10] Command [DesignerInvalidateConnection: CommmandUrl=DesignerInvalidateConnection] finished (13)
[17-Sep-2014 16:51:10] Request handled in 17.267ms
[17-Sep-2014 16:51:10] Handling with command: [DesignerInvalidateConnection: CommmandUrl=DesignerInvalidateConnection] (13)
[17-Sep-2014 16:51:10] Attempting to acquire command execution lock, timeout set to 00:10:00
[17-Sep-2014 16:51:10] Exception: Exception type: System.NullReferenceException
Object reference not set to an instance of an object
  at Mtb.Server.Commands.DesignerConnectionCommand.get_ConnectionAttributes () [0x00000] in <filename unknown>:0 
  at Mtb.Server.Commands.DesignerInvalidateConnection.HandleRequest (ILoggingHelper logger, System.Object commandRequestState) [0x00000] in <filename unknown>:0 
[17-Sep-2014 16:51:10] Command [DesignerInvalidateConnection: CommmandUrl=DesignerInvalidateConnection] finished (13)
[17-Sep-2014 16:51:10] Request handled in 8.289ms
Comment 5 Daniel Cazzulino 2014-09-29 13:59:16 UTC
For some reason, we're ending up with wrong version numbers than XI gives us. So on the Mac we have (say) 8.0.0.62 and in VS we get 8.0.62.0 (?!).

Also, we're off by one, which might be a side-effect of the circular dependency we have between XI and XVS. 

I'm currently investigating both issues.
Comment 6 Daniel Cazzulino 2014-09-29 17:06:57 UTC
Fixed in v3.7, build https://wrench.internalx.com/Wrench//ViewLane.aspx?lane_id=1227&host_id=63&revision_id=355205

Commit 10922d655c2e3403f04aae102361c9d2cc7fa41d (in v3.7).
Comment 7 Mohit Kheterpal 2014-09-30 15:29:50 UTC
I have checked this issue with XVS 3.6.262 and we are getting warning message for minor mismatch whenever we create or open iOS application in VS.

Screencast : http://screencast.com/t/58rNrcP2FN
Comment 8 Mohit Kheterpal 2014-10-01 06:45:19 UTC
I have checked this issue with XVS 3.7.188 + X.iOS 8.2.0.187 and now this issue is working fine i.e. we are not getting any error and warning message for minor missmatch.

Hence closing this issue.

Thanks