Bug 23391 - UIImagePickerController causes warning message when 2nd picture is taken
Summary: UIImagePickerController causes warning message when 2nd picture is taken
Status: RESOLVED UPSTREAM
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 8.0.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-09-25 23:25 UTC by Cody Beyer (MSFT)
Modified: 2014-11-07 13:23 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
TestCase (13.55 KB, application/zip)
2014-09-25 23:25 UTC, Cody Beyer (MSFT)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description Cody Beyer (MSFT) 2014-09-25 23:25:05 UTC
Created attachment 8198 [details]
TestCase

Snapshotting a view that has not been rendered results in an empty snapshot. Ensure your view has been rendered at least once before snapshotting or snapshot after screen updates.

in iOS8, the above error is created using the below steps on the attached test case:

- Run the camera

- Take a picture and USE the photo

- Run the camera again

- Black screen (if you take a picture, it will restart the preview window and all will work again until you USE photo)
Comment 1 Allan Ritchie 2014-09-26 08:59:17 UTC
This does lead to more serious issues in other apps.  In a couple of our apps, after using the photo, the preview screen becomes a black screen.  If you take another picture, it releases the preview screen again.  I do believe this is a bug in iOS8, not xamarin at this point as I have seen it in straight objective-c as well.
Comment 2 Atin 2014-10-06 08:02:38 UTC
I have downloaded the attached project and run it on iOS 8 device iPhone 4S and observed that its working fine. I have followed following steps :

1. Open attached project in XS
2. Deploy it on device 
3. click on camera
4. Take a picture and click on Use Photo
5. Again click on Camera

Observed that black screen is not appearing and I am able to take picture again and able to tap on use photo.

Please let me know if I have missed any step to reproduce it ?

Could you please share with which build you are getting this issue ?
Xamarin Studio->About Xamarin Studio->Show details

I am using following Environment :
=== Xamarin Studio ===

Version 5.5 (build 227)
Installation UUID: 45555ffd-f3f0-4f29-9543-e369d711ab7d
Runtime:
	Mono 3.10.0 ((detached/633e444)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000020

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.Mac ===

Version: 1.10.0.18 (Enterprise Edition)

=== Xamarin.iOS ===

Version: 8.2.0.193 (Enterprise Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Xamarin.Android ===

Version: 4.18.0 (Enterprise Edition)
Android SDK: /Users/xamarin77/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Build Information ===

Release ID: 505000227
Git revision: 7b721eeec7a2fa4c4f4de0ecd2aed4dc25edac95
Build date: 2014-10-02 15:53:38-04
Xamarin addins: 99ed56b428b31eba1efaace4d82188d6f334e6ca

=== Operating System ===

Mac OS X 10.9.5
Darwin Xamarin77s-Mac-mini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 3 Allan Ritchie 2014-10-06 13:30:52 UTC
It looks like this was a defect with iOS.  As of 8.0.2, we cannot reproduce the behavior.
Comment 4 Cody Beyer (MSFT) 2014-10-14 11:55:00 UTC
fixed in 8.0.2
Comment 5 Don French 2014-11-07 13:23:21 UTC
This is still an issue in 8.1. Ignoring the view and taking the picture will clear the issue.