Bug 2328 - When you have a 2.3 and 3.1 project in the same solution, can't deploy to 2.3 device
Summary: When you have a 2.3 and 3.1 project in the same solution, can't deploy to 2.3...
Status: RESOLVED INVALID
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-12-03 03:27 UTC by Jack Bond
Modified: 2016-08-03 15:24 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Jack Bond 2011-12-03 03:27:55 UTC
I have a shared library for two projects which has its min rev set to 2.3. The three projects are all in the same solution. One of the projects targets 2.3 while the other targets 3.1. When trying to deploy the 2.3 project to a 2.3 device, I get a deployment error complaining the device does not support the min version. If I remove the 3.1 project, with no other changes, the 2.3 project deploys.
Comment 1 Jonathan Pobst 2011-12-28 13:11:43 UTC
You probably need to go to the Configuration Build Manager and modify the Deploy checkboxes to only deploy the project you are working on.
Comment 2 Jonathan Pobst 2012-02-08 17:12:22 UTC
I think this is working as intended via the Deploy setting.  If not, please reopen!