Bug 2307 - ngit doesn't understand git aliases
Summary: ngit doesn't understand git aliases
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Version Control ()
Version: Trunk
Hardware: PC Linux
: Low normal
Target Milestone: ---
Assignee: Alan McGovern
URL:
Depends on:
Blocks:
 
Reported: 2011-12-02 02:08 UTC by Stephen Shaw
Modified: 2012-03-06 09:24 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Stephen Shaw 2011-12-02 02:08:17 UTC
If I'm working on a project that that I cloned using an alias. ie.
git clone gnomec:f-spot

I can perform actions that can be done locally like git log, but if I do something like update I get an exception:

NGit.Errors.TransportException: gnomec:f-spot: No such host is known
  at NGit.Transport.JschConfigSessionFactory.GetSession (NGit.Transport.URIish uri, NGit.Transport.CredentialsProvider credentialsProvider, NGit.Util.FS fs, Int32 tms) [0x00000] in <filename unknown>:0 
  at NGit.Transport.SshTransport.GetSession () [0x00000] in <filename unknown>:0 
  at NGit.Transport.TransportGitSsh+SshFetchConnection..ctor (NGit.Transport.TransportGitSsh _enclosing) [0x00000] in <filename unknown>:0


My alias is:
[url "ssh://user@git.gnome.org/git/"]
        insteadof = gnomec:
Comment 1 Alan McGovern 2012-02-13 11:01:45 UTC
I think this is supported with MonoDevelop master but I am unsure how to set up the url alias to test. Would you be able to tell me what git commands I need to run to generate the alias so I can trigger this issue?
Comment 2 Alan McGovern 2012-02-13 11:17:03 UTC
Ah, I reproed the issue and it is not fixed. I'll look into it now and see if I can figure out why the alias isn't being resolved properly.
Comment 3 Alan McGovern 2012-03-06 09:24:22 UTC
The fix has been upstreamed to jgit and committed there so I'm just updating monodevelop to the latest version. The fix should make 2.8.8 final.