Bug 23021 - Calls from generic shared methods not always patched
Summary: Calls from generic shared methods not always patched
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: JIT ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2014-09-15 15:28 UTC by Zoltan Varga
Modified: 2014-12-01 06:49 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Zoltan Varga 2014-09-15 15:28:34 UTC
From:

https://xamarin.desk.com/agent/case/88533

Calls made from generic shared code sometimes hit this case in mini-trampolines.c:

			if (ji && target_ji && generic_shared && ji->has_generic_jit_info && !target_ji->has_generic_jit_info) {
				/* 
				 * Can't patch the call as the caller is gshared, but the callee is not. Happens when
				 * generic sharing fails.
				 * FIXME: Performance problem.
				 */
				no_patch = TRUE;
Comment 1 Zoltan Varga 2014-09-16 23:18:30 UTC
Committed a fix to mono master 5dbf97e66057f8626c53fcea30f1988d6627e5a2.
Comment 2 Zoltan Varga 2014-09-22 17:08:49 UTC
-> FIXED.
Comment 5 Ram Chandra 2014-12-01 06:49:58 UTC
@Zoltan: Thanks for the test case.

I have checked this issue with following builds:

Mac OS X 10.10.0
Xamarin Studio: 5.7 (build 596)
Mono 3.12.0 ((detached/b75fa2b)
GTK+ 2.24.23 (Raleigh theme)
Xcode 6.1 (6604)
Xamarin.iOS : 8.6.0.5 (Trial Edition)
=== Build Information ===
Release ID: 507000596
Git revision: d996e9ba6874a0d64241e43e5e6b06322ce29c84
Build date: 2014-11-25 17:17:54-05
Xamarin addins: 8ca19707b41536a391f53364ee4ff9272711feb0

I have checked this issue on Xcode instrument and observed that the performance of app is improved  both at launch and in button tap operations.

Screencast: http://www.screencast.com/t/mn7AJEPdq3o4

This issue has been fixed. Hence I am closing this issue.












Screencast:

This issue has been fixed. Hence I am closing this issue.