Bug 2300 - Fail to run app when creating custom AdapterView class
Summary: Fail to run app when creating custom AdapterView class
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries ()
Version: 1.9.3
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-12-01 16:12 UTC by Jonathan Clement
Modified: 2012-09-24 06:00 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Repro (17.38 KB, application/zip)
2011-12-01 16:12 UTC, Jonathan Clement
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jonathan Clement 2011-12-01 16:12:15 UTC
Created attachment 982 [details]
Repro

1- Create a class that derived from AdapterView<BaseAdapter>.
2- Compile the application.
3- Run -> Fails with these errors :


Error:  exactmodus.core.mdroid.HorizontalListView is not abstract and does not override abstract method setAdapter(android.widget.Adapter) in android.widget.AdapterView
public class HorizontalListView

Error:  getAdapter() in exactmodus.core.mdroid.HorizontalListView cannot override getAdapter() in android.widget.AdapterView; attempting to use incompatible return type
found   : java.lang.Object
required: android.widget.Adapter
	public java.lang.Object getAdapter ()


(+ the same error for the setter)

In the repro, the file HorizontalListViewTest.cs illustrate the problem.
Comment 1 Atsushi Eno 2012-09-24 06:00:28 UTC
-> Class Libraries

This does not occur anymore. Thanks for the report.