Bug 2292 - When try to install the solution to a desired location, it always installs under C:\Program Files (x86).
Summary: When try to install the solution to a desired location, it always installs un...
Status: CONFIRMED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model ()
Version: unspecified
Hardware: PC Windows
: Lowest normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 1448 1765 ()
Depends on:
Blocks:
 
Reported: 2011-12-01 05:18 UTC by Jatin
Modified: 2015-07-31 10:03 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 2292 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Jatin 2011-12-01 05:18:09 UTC
Step To Reproduce:

1.Launch the MonoDevelop.
2.Click on "Start a New Solution" link.
3.Choose C# > Mono for Android in left hand panel.
4.Select Mono for Android Application from the center panel.
5.Enter any name into Name field.
6.Click on "Ok" button.
7.Right Click on Solution/Project name. 
8.Click on the option "Tools"
9.Click on the option "Install".
10.Provide the desired location and click on OK button.
11.Observe that it does not install at the desired location, rather it always installs under C:\Program Files (x86).  

Actual result:

When try to install the solution to a desired location, it always installs under C:\Program Files (x86), regardless of the location provided.

Expected result:

It should always install at the provided location.

Environment:
MonoDevelop 2.8.4-1
Mono for Android 4.0.0-12
Windows 7
Comment 1 Mikayla Hutchinson [MSFT] 2011-12-01 12:26:23 UTC
Technically this is a usability issue, not a bug. The location is an "installation prefix" which is a very Unixy concept. IMO we should remove the packaging addin completely until we have time to redesign it, since it's mostly just confusing.
Comment 2 Alan McGovern 2011-12-08 20:27:07 UTC
Is this something we should do now?
Comment 3 Alan McGovern 2011-12-08 20:35:19 UTC
*** Bug 1765 has been marked as a duplicate of this bug. ***
Comment 4 Alan McGovern 2011-12-08 20:38:30 UTC
*** Bug 1448 has been marked as a duplicate of this bug. ***
Comment 5 Alan McGovern 2011-12-08 20:39:06 UTC
Some of the bugs I've marked as duplicates are issues with this feature. Maybe i shouldn't be marking them as dupes.