Bug 2288 - Ctrl+Alt combinations don't get handled
Summary: Ctrl+Alt combinations don't get handled
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: Trunk
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Mikayla Hutchinson [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2011-12-01 02:25 UTC by Lopatkin Ilja
Modified: 2011-12-06 20:38 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Lopatkin Ilja 2011-12-01 02:25:23 UTC
I've just updated to trunk version and all my Ctrl+Alt+... bindings stopped working.
I may guess that the problem is somewhere in GtkWorkarounds.cs and was introduced by this commit https://github.com/mono/monodevelop/commit/c827464abb033569ec9f346482aa3c2b6f2c06af because build from 9th November works fine.
OS is Windows 7.
Comment 1 Mike Krüger 2011-12-06 04:51:34 UTC
mhutch: Can you take a look at it ?
Comment 2 Mikayla Hutchinson [MSFT] 2011-12-06 12:34:20 UTC
Yup, I can repro this.
Comment 3 Mikayla Hutchinson [MSFT] 2011-12-06 20:38:12 UTC
Fixed in git.