Bug 22835 - NavigationPane PushAsync to page with Grid or StackLayout not working on iOS
Summary: NavigationPane PushAsync to page with Grid or StackLayout not working on iOS
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.3
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-09-10 13:04 UTC by Michael L Perry
Modified: 2014-11-13 09:09 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Michael L Perry 2014-09-10 13:04:33 UTC
I'm seeing a strange and inconsistent bug on Xamarin Forms for iOS. When I use PushAsync in a NavigationPane to navigate to a page with a Grid or a StackLayout, the navigation silently fails. If I change the page to instead have a single top-level ListView, then it works. Furthermore, navigation to the Grid or StackLayout version of the page works on Windows Phone and Android.

The commit where I go from failing to working is here: https://github.com/michaellperry/Festify/commit/81617dd1a6db74d381fbf7ce55e428c9cfd5094e

This project still has a third page, which is using Grid and still experiencing the inconsistent bug. I can navigate to the third page on the other platforms.

If you need a simpler repro, it may take me a day or two to create one.
Comment 1 Michael L Perry 2014-09-10 21:47:37 UTC
I found that this works in the simulator. I have been testing with an iPad 1 (iOS 5.1.1), which faithfully reproduces the bug. This may not be an issue on current devices.
Comment 2 Ram Chandra 2014-09-11 09:36:07 UTC
I have checked this issue but I am unable to reproduce this issue.

Could you please provide a sample application and build information ? So, that we can reproduce this issue at our end.

You can get build information from here:

Click on Visual Studio Help menu => About Microsoft Visual Studio => Copy Info.



Environment Info:

Xamarin.Forms: 1.2.2.0

Windows:

Windows 7
Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.50938
Installed Version: Professional
Xamarin   3.5.55.0 (2db5ccd228887372e207e112bc3b5f1b16b24293)

Mac:

Mac OS X 10.9.3
Mono 3.8.0 ((no/45d0ba1)
Xcode 5.1 (5084)
Xamarin.iOS: 7.4.0.108 (Enterprise Edition)
Comment 3 Michael L Perry 2014-11-11 17:36:49 UTC
I have been unable to reproduce this bug myself. It only occurred once. Please close. I'll capture more information if it happens again.
Comment 4 Ram Chandra 2014-11-13 09:09:09 UTC
As per "Comment 3" I am closing this issue.

Please reopen this issue if you get the same behavior again.