Bug 22823 - [iOS] Last ToolBarItem not displayed with Master Detail Controller in Landscape mode
Summary: [iOS] Last ToolBarItem not displayed with Master Detail Controller in Landsca...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.2
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-09-10 09:01 UTC by Prashant Cholachagudda
Modified: 2016-03-16 12:35 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Prashant Cholachagudda 2014-09-10 09:01:36 UTC
Last ToolBarItem not displayed with Master Detail Controller in Landscape mode.

All toolbar items are displayed for the first time, as soon as we select sidebar item the last toolbar item
disappears.

Test case: https://www.dropbox.com/s/rjvqf5lnhiuidug/TooBarIssue.zip?dl=0
Screencast: http://www.screencast.com/t/7xZXKkKQ
Comment 1 Parmendra Kumar 2014-09-11 09:47:36 UTC
I have checked this issue and I am unable to reproduce this issue, I am unable to debug successfully the attached sample project. When we debug the attached sample project it throw a error "The Nuget package is missing" 
Please check the attached screencast and Please Let we know i I am missing anything?.  

Screencast:http://screencast.com/t/sl2QhIlmZtIh
Build OutputLog: https://gist.github.com/saurabh360/54bb61d95daa3c641961
Error:https://gist.github.com/saurabh360/2ebf45fdebb2d685e6b0

Environment Info:
=== Xamarin Studio ===

Version 5.3 (build 441)
Installation UUID: 1a096c6f-0678-402e-89b2-a2c10f7e80e4
Runtime:
	Mono 3.8.0 ((no/45d0ba1)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000009

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.Mac ===

Version: 1.10.0.10 (Business Edition)

=== Xamarin.Android ===

Version: 4.16.0 (Business Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.iOS ===

Version: 7.4.0.108 (Business Edition)
Hash: 77efa3f
Branch: 
Build date: 2014-08-26 07:59:55-0400

=== Build Information ===

Release ID: 503000441
Git revision: befb6aa1176d37a5f678f4274f340a0159091b7a
Build date: 2014-09-08 17:57:02-04
Xamarin addins: 6dc7c388e31fdfc8014689839d37de0d4622435c

=== Operating System ===

Mac OS X 10.9.4
Darwin ShrutiMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 2 Prashant Cholachagudda 2014-09-11 10:20:08 UTC
@Parmendra You need to add the Xamarin.Forms nugget packages to the projects.

Select Project -> Add Packages... menu, search for Xamarin.Forms package and 
at last click on Add Package button.
Comment 3 Parmendra Kumar 2014-09-11 11:01:24 UTC
Hi Prashant,
                   As per the comment 2, I have add the Xamarin.Forms nuget packages to the projects., But I am getting the same error.

Screencast: http://screencast.com/t/I9I0ug0uga6Y
Comment 5 Parmendra Kumar 2015-01-12 04:47:47 UTC
@Prashant, Could you please reattach the sample project because, Today we are not able to download the attach sample?
Comment 6 Jason Smith [MSFT] 2016-03-16 12:35:59 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we no longer believe it affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team