Bug 22802 - Build fails when x86_64 support is enabled
Summary: Build fails when x86_64 support is enabled
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: 7.9.2.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-09-09 19:09 UTC by Paola Villarreal
Modified: 2014-09-11 13:46 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Paola Villarreal 2014-09-09 19:09:29 UTC
When enabling both x86_64 and i386 + x86_64 architecture on "iOS Build" -> Advanced you won't be able to build the app, with this error:  ld: symbol dyld_stub_binding_helper not found, normally in crt1.o/dylib1.o/bundle1.o for architecture x86_64

Build log: https://gist.github.com/pa-w/c61daff48b15934db14d

Versions:
Xamarin Studio: 5.4 (build 215)
Xamarin.iOS: 7.9.4.23 
Xcode: Version 6.0 (6A313)

How to reproduce:

1. Open any sample from monotouch-samples (unified_api branch)
2. Go to iOS Build -> Advanced on the project's options.
3. Select either x86_64 or i386 + x86_64 as supported architectures
4. Build
Comment 1 Rolf Bjarne Kvinge [MSFT] 2014-09-10 03:28:44 UTC
> --targetver "3.0"

Try setting Deployment Target to something higher (I believe 5.1.1 is the minimum for 64-bit apps).
Comment 2 Sebastien Pouliot 2014-09-11 13:38:11 UTC
We should issue a MTxxxx error in such cases. The user is asking for something that we (well Apple) can't provide.

@Paola a confirmation would still be nice (in case this hides another issue).
Comment 3 Rolf Bjarne Kvinge [MSFT] 2014-09-11 13:46:30 UTC
We already emit an MT0047 error code, the version Paola is using just doesn't have it yet.