Bug 22783 - App crashes while debugging (seems related to breakpoints?)
Summary: App crashes while debugging (seems related to breakpoints?)
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: 7.2.6
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-09-09 11:15 UTC by Jeffrey Stedfast
Modified: 2016-05-25 01:01 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Jeffrey Stedfast 2014-09-09 11:15:17 UTC
I'll let BB explain the details.
Comment 1 Sadik Ali 2014-09-10 04:42:12 UTC
I tried to reproduce this issue but unable to reproduce this issue.

Could you please provide sample application or steps to reproduce this issue? So the we can reproduce this issue at our end.
Comment 2 Cody Beyer (MSFT) 2014-09-18 13:04:03 UTC
This forum post has further details:

https://forums.xamarin.com/discussion/8151/breakpoints-cause-app-to-crash-in-new-android-version-4-2-2
Comment 3 Brad Moore 2014-09-26 20:02:57 UTC
Forum post is specifically about Android I believe.
For me creating a new project thismorning allowed breakpointing. I also noticed new projects Debug|iPhone linker setting was SDK Assemblies only. Not sure if that is usually that by default but changing it around did not seem to help.

Two of my existing projects however, app just closes when it hits a breakpoint.

http://forums.xamarin.com/discussion/comment/78888
is a forum post that I put my crashlog in if that helps at all.
Comment 4 Zoltan Varga 2014-09-26 21:13:27 UTC
Could you attach the project which exhibits the problem or a small testcase ?
Comment 5 Brad Moore 2014-09-27 02:48:21 UTC
Turns out removing TestFlight from my app (not just the TestFlight.SetReportCrashes(true); line, but the TestFlight.TakeOff("key"); in particular).

Can repeat it again and again by uncommenting that one line and readding it. Don't think I had this issue in the past, seems to be new to iOS8. Have been using TestFlight 3.0.2 SDK for quite a while now, but was very recent this issue had started happening.
Comment 6 Zoltan Varga 2014-09-27 15:15:40 UTC
Its possible that TestFlight is interfering with the debugger, since the two use similar os fuctionality.
Comment 8 Sebastien Pouliot 2016-05-25 01:01:24 UTC
We have not received a test case. If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!