Bug 2277 - When I create an NUnit Project and run the tests, I get a NullReferenceException from RealProxy.PrivateInvoke
Summary: When I create an NUnit Project and run the tests, I get a NullReferenceExcept...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit ()
Version: 2.6
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Alan McGovern
URL:
Depends on:
Blocks:
 
Reported: 2011-11-30 15:22 UTC by Tim Stewart
Modified: 2012-12-03 12:06 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Tim Stewart 2011-11-30 15:22:31 UTC
Description of Problem:


Steps to reproduce the problem:
1. File | New | Solution...
2. Select C# | NUnit | NUnit Library Project
3. Enter Name for Project (e.g. Test).
4. Don't select any project Features, but click the OK button.
5. Select the Unit Tests tab.
6. Right-click on the root node (Test) and select Run Test



Actual Results:
Test Results tab shows: 
Internal Error
NullReferenceException: Object reference not set to an instance of an object
StackTrace
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(....) [0x00000] in <filename unknown>:0


Expected Results:
My test to run

How often does this happen? 
Every time on two different installations of Ubuntu

Additional Information:

 % uname -a
Linux timbuntu 3.0.0-13-generic-pae #22-Ubuntu SMP Wed Nov 2 15:17:35 UTC 2011 i686 i686 i386 GNU/Linux

 % mono --version
Mono JIT compiler version 2.10.5 (Debian 2.10.5-1)
Copyright (C) 2002-2011 Novell, Inc, Xamarin, Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  x86
        Disabled:      none
        Misc:          softdebug 
        LLVM:          supported, not enabled.
        GC:            Included Boehm (with typed GC and Parallel Mark)
Comment 1 Mike Krüger 2012-01-04 04:24:58 UTC
2.6 is outdated - should work in 2.8.