Bug 22754 - Inform the user that Xcode might be missing
Summary: Inform the user that Xcode might be missing
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.5
Hardware: PC Mac OS
: --- enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-09-08 15:21 UTC by John Miller [MSFT]
Modified: 2015-10-19 10:37 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Miller [MSFT] 2014-09-08 15:21:48 UTC
**Overview:**

   If the Mac build host does not have Xcode installed (but it does have the Xamarin tooling installed), the pairing dialog in Visual Studio will say that the pairing key is invalid. 

**Steps to Reproduce:**

   1. Make sure that Xamarin tooling is installed on the Mac build host, but Xcode is missing. 
   2. Try and pair Xamarin for VS to that build host. 

**Actual Results:**

   It will say that the pairing key is invalid. 

**Expected Results:**

   Some error message that indicates there is an issue with the xcode-select, etc. 

**Build Date & Platform:**

   XVS 3.5

**Additional Information:**

   The log files from VS do show this error message:
>Xamarin.VisualStudio.IOS.MonoTouchPackage Information: 0 : [2014-09-08 11:27:52.0] [2014-09-08 18:27:52.0] xcode-select: >error: unable to get active developer directory, use `xcode-select --switch` to set one (or see `man xcode-select`)
Comment 1 Joaquin Jares 2015-10-19 10:37:29 UTC
In 4.0 we have an error that states "Xcode is not installed. Please install Xcode and try to reconnect to Xamarin Mac Agent server"