Bug 22685 - Assertion at mini.c:4656, condition `cfg->code_size - cfg->epilog_begin < 0xffff' not met
Summary: Assertion at mini.c:4656, condition `cfg->code_size - cfg->epilog_begin < 0xf...
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: 3.8.0
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-09-05 06:32 UTC by mrt690
Modified: 2017-08-28 15:04 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Stackrace of crash, txt (1.45 KB, text/plain)
2014-09-05 06:32 UTC, mrt690
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description mrt690 2014-09-05 06:32:28 UTC
Created attachment 7945 [details]
Stackrace of crash, txt

I am hosting a Terraria Server on a Debian Wheezy root server with mono 3.2.8.
Yesterday I compiled mono 3.8.0 and wanted to test it. Well, few seconds after the first player joins, the Terraria Server crashes with a stackrace (attachment).

I didn't tried any versions between 3.2.8 and 3.8.0.
Someone in IRC asked me to try it with latest buildable master from git, but the compile failed, cause a module was too new from my already existant mono 3.8.0 (wtf?).

I can't provide some simple steps to reproduce.
You will need to extract the latest tShock build and run it with mono and connect to it.
https://github.com/NyxStudios/TShock/releases/download/v4.2301/TShock.4.2.3.0720.zip
Comment 1 mrt690 2014-09-05 13:11:10 UTC
I just compiled mono 3.6.0 and the exact same Terraria Server runs fine on it.
Comment 2 Zoltan Varga 2014-09-05 18:10:01 UTC
As a workaround, try building/using a 32 bit mono instead of a 64 bit version.
Comment 3 Zoltan Varga 2014-09-05 18:10:17 UTC
Fixed in mono master/mono-3.10.0-branch.