Bug 22556 - MT9008 with Indie license
Summary: MT9008 with Indie license
Status: VERIFIED DUPLICATE of bug 24011
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 8.0.0
Hardware: Macintosh Mac OS
: Normal blocker
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
: 22481 22721 22956 ()
Depends on:
Blocks:
 
Reported: 2014-09-01 23:53 UTC by blueapple_s
Modified: 2017-05-22 17:13 UTC (History)
21 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
output of script (3.49 MB, application/octet-stream)
2014-10-14 09:18 UTC, troy-dawson
Details
Output from Diagnostics project (383.12 KB, application/zip)
2014-10-14 13:36 UTC, Magnus Johansson
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED DUPLICATE of bug 24011

Description blueapple_s 2014-09-01 23:53:42 UTC
Description of Problem:
alpha channel of xamarin studio fails compiling ios8 app with this error : 
Error MT9008: Building from the command-line requires a Business license. (MT9008)

Steps to reproduce the problem:
1. press the play button 
2. error happens


Actual Results:


Expected Results:


How often does this happen? 
every time i try to compile

Additional Information:

build log :

Building: comicrocket (Debug|iPhoneSimulator)
Performing main compilation...
/Library/Frameworks/Mono.framework/Versions/3.8.0/bin/mcs /noconfig "/r:/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/mscorlib.dll" -nostdlib "/out:/Users/sorob/comicrocket/ios_universal/ios/comicrocket/bin/iPhoneSimulator/Debug/comicrocket.exe" "/r:/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/System.dll" "/r:/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/System.Xml.dll" "/r:/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/System.Core.dll" "/r:/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/monotouch.dll" "/r:/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/System.Json.dll" "/r:/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/System.Net.dll" "/r:/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/System.Web.Services.dll" "/r:/Users/sorob/comicrocket/ios_universal/ios/XibFree/bin/Debug/XibFree.dll" "/r:/Users/sorob/Downloads/monotouch-bindings-master/ATMHud/binding/ATMHud.dll" "/r:/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/MonoTouch.Dialog-1.dll" "/r:/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/System.Core.dll" /nologo /warn:4 /debug:full /optimize- /codepage:utf8 "/define:DEBUG"  "/define:__MOBILE__"  "/define:__IOS__"  /t:exe "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Main.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/AppDelegate.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/LoginScreen.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/TabViewController.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Models/ApiController.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/Populars.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/Picks.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/TableViewBaseScreen.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Dispatcher.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/SubViews/WebSubView.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/Genres.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/WebViewerScreen.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/SubViews/ThrottledHttp.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/SubViews/ImageDownloader.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/SubViews/UIKitImageDownloader.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/Markeds.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/Search.cs" "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/About.cs" 
Compilation succeeded - 9 warning(s)

/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/Genres.cs(45,31): warning CS0108: `comicrocket.Screens.Genres._items' hides inherited member `comicrocket.Screens.TableViewBaseScreen._items'. Use the new keyword if hiding was intended
/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/TableViewBaseScreen.cs(173,25): (Location of the symbol related to previous warning)
/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Models/ApiController.cs(204,8): warning CS0219: The variable `filename' is assigned but its value is never used
/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/Genres.cs(70,16): warning CS0108: `comicrocket.Screens.Genres.Source' hides inherited member `comicrocket.Screens.TableViewBaseScreen.Source'. Use the new keyword if hiding was intended
/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/TableViewBaseScreen.cs(402,16): (Location of the symbol related to previous warning)
/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/Genres.cs(124,17): warning CS0108: `comicrocket.Screens.Genres.TableViewCell' hides inherited member `comicrocket.Screens.TableViewBaseScreen.TableViewCell'. Use the new keyword if hiding was intended
/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/TableViewBaseScreen.cs(175,16): (Location of the symbol related to previous warning)
/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/TableViewBaseScreen.cs(336,41): warning CS0414: The private field `comicrocket.Screens.TableViewBaseScreen.TableViewCell.images' is assigned but its value is never used
/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/WebViewerScreen.cs(375,8): warning CS0414: The private field `comicrocket.WebViewerScreen.hasSetZoomValue' is assigned but its value is never used
/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/About.cs(12,23): warning CS0414: The private field `comicrocket.Screens.About.tableView' is assigned but its value is never used
/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/About.cs(16,15): warning CS0414: The private field `comicrocket.Screens.About.sorobLogo' is assigned but its value is never used
/Users/sorob/comicrocket/ios_universal/ios/comicrocket/Screens/About.cs(17,11): warning CS0414: The private field `comicrocket.Screens.About.sorobLink' is assigned but its value is never used


Build complete -- 0 errors, 9 warnings

Compiling to native code
/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mtouch -sdkroot "/Applications/Xcode6-Beta6.app/Contents/Developer" --cache "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/obj/iPhoneSimulator/Debug/mtouch-cache" --nomanifest --nosign -sim "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/bin/iPhoneSimulator/Debug/comicrocket.app" -r "/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/System.dll" -r "/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/System.Xml.dll" -r "/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/System.Core.dll" -r "/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/monotouch.dll" -r "/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/System.Json.dll" -r "/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/System.Net.dll" -r "/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/System.Web.Services.dll" -r "/Users/sorob/comicrocket/ios_universal/ios/XibFree/bin/Debug/XibFree.dll" -r "/Users/sorob/Downloads/monotouch-bindings-master/ATMHud/binding/ATMHud.dll" -r "/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/2.1/MonoTouch.Dialog-1.dll" -debug -nolink -sdk "8.0" -targetver "6.0" --abi=i386 "/Users/sorob/comicrocket/ios_universal/ios/comicrocket/bin/iPhoneSimulator/Debug/comicrocket.exe"
Xamarin.iOS 7.9.4 Indie Edition using framework: /Applications/Xcode6-Beta6.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator8.0.sdk
error MT9008: Building from the command-line requires a Business license.

---------------------- Done ----------------------

Build: 1 error, 9 warnings
Comment 1 Rolf Bjarne Kvinge [MSFT] 2014-09-03 04:04:03 UTC
Probably a dup of #22481
Comment 2 Saurabh 2014-09-03 10:22:52 UTC
I have also checked the Issue with iOS 8 sample "ImageInverter" when license is Starter. When I run the application I am getting build error "Building from the command-line requires a Business license"

Build Output: https://gist.github.com/saurabh360/c7d8399283ece3141c95
IDE Log: https://gist.github.com/saurabh360/7d66b459c4282df7dfcc

X.S 5.4 (Build 184)
Git revision: 8c98fc4b6482790b1d585ff8a4118a08367e417c

However with X.S 5.3 (Build 440) I am not getting this error.
Comment 3 Sebastien Pouliot 2014-09-03 11:42:18 UTC
This is an indirect effect of the code signing requirement changes from Apple. It will be fixed in future releases.
Comment 4 Sebastien Pouliot 2014-09-03 11:52:00 UTC
-> Jeff (wrt discussion with Rolf)
Comment 5 Jeffrey Stedfast 2014-09-03 12:56:49 UTC
ok, this should be fixed now
Comment 6 Rolf Bjarne Kvinge [MSFT] 2014-09-03 13:25:17 UTC
*** Bug 22481 has been marked as a duplicate of this bug. ***
Comment 7 Saurabh 2014-09-04 03:32:34 UTC
I have checked this Issue with latest build of X.S 5.4 (Build 191) I am still getting this error. Please let me know Is it fixed with this build or fixed build has to come?
Build Output: https://gist.github.com/saurabh360/33e667df88d3b30c96bc

X.S 5.4 (Build 191)
Git revision: 704aa5d74db4e95e6c7bb6da0687475f5ace8c6b
X.iOS 7.9.4.29
Comment 8 Mohit Kheterpal 2014-09-08 09:44:24 UTC
I have checked this issue with XS 5.4 (build 206) and I am still getting this issue as shown in screencast : http://www.screencast.com/t/jtV7dIgfa4b

Hence Reopening this issue.

Environment info :
=== Xamarin Studio ===

Version 5.4 (build 206)
Installation UUID: 0b7eaebc-a0ed-4b58-81df-91e378cad28c
Runtime:
	Mono 3.8.0 ((no/45d0ba1)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000009

=== Apple Developer Tools ===

Xcode 6.0 (6256.20)
Build 6A280n

=== Xamarin.iOS ===

Version: 7.9.5.14 (Starter Edition)
Hash: 828bf09
Branch: 
Build date: 2014-09-06 14:00:12-0400

=== Xamarin.Android ===

Version: 4.17.0 (Starter Edition)
Android SDK: /Users/Admin_Mac/Desktop/Anddk/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

=== Xamarin.Mac ===

Version: 1.11.0.1 (Starter Edition)

=== Build Information ===

Release ID: 504000206
Git revision: f4eb04462127b0dbe511662e6ed7399f50fdf531
Build date: 2014-09-07 16:41:45-04
Xamarin addins: 9c62b69db7a6c1a887954dad2d421972ad4cb948

=== Operating System ===

Mac OS X 10.10.0
Darwin Admin-Macs-Mac-mini.local 14.0.0 Darwin Kernel Version 14.0.0
    Mon Aug 25 20:37:34 PDT 2014
    root:xnu-2782.1.1.1.1~1/RELEASE_X86_64 x86_64
Comment 9 Jeffrey Stedfast 2014-09-08 11:59:26 UTC
*** Bug 22721 has been marked as a duplicate of this bug. ***
Comment 10 Jeffrey Stedfast 2014-09-08 12:08:01 UTC
The previous fix in Xamarin Studio wasn't quite right (fixed now), but that doesn't explain why bug #22721 (which is using Xamarin Studio 5.2.1 and not a 5.4 alpha release) is having this problem...
Comment 11 Mohit Kheterpal 2014-09-09 09:29:53 UTC
I have tried to verify this issue with XS 5.4 (build 214) and I am still getting same build error with starter license.

Please let me know, is the fixed applied in XS 5.4(build 214)Git revision: f702dcee9f4a942a68c70228bbf7f8e6b4871e24 or I have to verify this issue with some other build ?

As of now I am reopening this issue.
Comment 13 Jeffrey Stedfast 2014-09-10 23:00:46 UTC
Reassigning to Xamarin.iOS because the PKG_CONFIG_PATH problem is fixed which means that this is no longer a Xamarin Studio issue.
Comment 14 Rolf Bjarne Kvinge [MSFT] 2014-09-11 08:03:11 UTC
Fixed.

maccore/master: 49d53849056dc0c88da85d14fc0a333d271282a1
monotouch/master: 60469c2bf6c3c9394c1cbaece969b3e8025635a3

Pending backports to XI 8 and XM.
Comment 15 Rolf Bjarne Kvinge [MSFT] 2014-09-11 09:29:39 UTC
Backported to XI 8

maccore/ios8-7.4.0: 81a9b0045f3ffc2b7bfaf48881c6ac47d73ee3e1
monotouch/monotouch-8.0.0-branch:
Comment 16 Rolf Bjarne Kvinge [MSFT] 2014-09-11 09:30:09 UTC
Backported to XI 8

maccore/ios8-7.4.0: 81a9b0045f3ffc2b7bfaf48881c6ac47d73ee3e1
monotouch/monotouch-8.0.0-branch: cca01694c157fe2f7996545427a7a41337e982bf

XM still pending.
Comment 18 Prashant manu 2014-09-15 02:39:50 UTC
*** Bug 22956 has been marked as a duplicate of this bug. ***
Comment 19 Mohit Kheterpal 2014-09-17 09:33:45 UTC
I have checked this issue and we are able to build iOS8 app (ImageInverter) when license is starter on disk as shown in screencast : http://www.screencast.com/t/AKdzob4CO6n

Hence closing this issue.

Environment info : 
Xamarin Studio
Version 5.4 (build 239)
Installation UUID: 0b7eaebc-a0ed-4b58-81df-91e378cad28c
Runtime:
	Mono 3.8.0 ((no/45d0ba1)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000009

Apple Developer Tools
Xcode 6.0 (6299)
Build 6A313

Xamarin.iOS
Version: 8.0.0.60 (Business Edition)
Hash: b26679f
Branch: 
Build date: 2014-09-16 12:47:14-0400

Xamarin.Android
Version: 4.17.0 (Starter Edition)
Android SDK: /Users/Admin_Mac/Desktop/Anddk/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

Xamarin.Mac
Version: 1.11.0.1 (Starter Edition)

Build Information
Release ID: 504000239
Git revision: 338110385bb89c5774e89ffcb15d8f2039e7fbcd
Build date: 2014-09-16 12:25:53-04
Xamarin addins: 05241f5ab70cf79388a0f113bc6877780ed1024a

Operating System
Mac OS X 10.10.0
Comment 20 Magnus Johansson 2014-09-17 15:18:07 UTC
I am now getting this error on Stable channel v5.3.1 (build 2).
(There was s small update on the Stable channel the other day)
Comment 21 troy-dawson 2014-09-17 21:05:24 UTC
This is still not fixed for building Xamarin.Mac projects with an Indlie license.

Xamarin Studio
Version 5.4 (build 239)

I can build iOS apps for the simulator with Indie Starter, so this issue is not actually fixed.
Comment 22 Chris Hamons 2014-09-17 21:43:06 UTC
Sorry, this fix was deployed and then found to have a subtle breaking effect upon Xamarin.iOS so we pulled it. We're going to fix this and then redeploy.
Comment 23 peter cresswell 2014-09-17 23:06:14 UTC
Any work around for this? Is the alpha channel currently working?

 I've just updated to v5.3 build 441 with Indie license and am getting this error when building against IOS 7.1 iPad app.
Comment 24 Chris Hamons 2014-09-19 11:46:51 UTC
The fix should be in stable again. Try updating and see if it fixes you.
Comment 25 Magnus Johansson 2014-09-19 16:03:20 UTC
Nope, sorry guys.

On stable channel, just received Version 5.4 (build 240), and guess what, this just appeared:
Error MT9008: Building from the command-line requires a Business license. (MT9008) 

Please get your act together, this is not fun anymore.
Comment 26 Chris Hamons 2014-09-19 16:07:08 UTC
Magnus, what version of Xamarin.Mac do you have? You'll need both a XS and a XM that have the fix.
Comment 27 Magnus Johansson 2014-09-19 16:15:18 UTC
None. This is on a iOS app.
Comment 28 Chris Hamons 2014-09-19 16:17:40 UTC
Sorry, there are people on this thread talking about hitting this on Xamarin.Mac and some Xamarin.iOS. What version of Xamarin.iOS do you have?
Comment 29 Magnus Johansson 2014-09-19 16:25:16 UTC
Here's what works for me (scroll down to what doesn't work(gives the error reported):
=== Xamarin Studio ===

Version 5.3 (build 441)
Installation UUID: 9428fc90-fb5b-413b-abd8-1f6daca5faf3
Runtime:
	Mono 3.8.0 ((no/45d0ba1)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000009

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.Mac ===

Version:

=== Xamarin.iOS ===

Version: 8.0.0.62 (Indie Edition)
Hash: 8bd8158
Branch: 
Build date: 2014-09-18 09:12:55-0400

****************** 
****************** 
****************** 
****************** 
This is what doesn't work:

=== Xamarin Studio ===

Version 5.4 (build 240)
Installation UUID: 9428fc90-fb5b-413b-abd8-1f6daca5faf3
Runtime:
	Mono 3.8.0 ((no/45d0ba1)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000009

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.iOS ===

Version: 8.0.0.62 (Indie Edition)
Hash: 8bd8158
Branch: 
Build date: 2014-09-18 09:12:55-0400
Comment 30 Rolf Bjarne Kvinge [MSFT] 2014-09-19 18:52:03 UTC
I'm not able to reproduce the MT9008 error with the versions from comment #29. Are you on Mavericks or Yosemite?
Comment 31 Magnus Johansson 2014-09-19 19:10:27 UTC
Currently on Yosemite, but I had the same problem on Mavericks: https://bugzilla.xamarin.com/show_bug.cgi?id=22956
Comment 32 troy-dawson 2014-09-19 22:49:34 UTC
Still broken building a new Xamarin.Mac unified project on Mavericks 10.10 (14A361c)

MMPTASK: error MM9008: Building from the command-line requires a Business license.
	Task "MmpTask" execution -- FAILED
	Done building target "_CompileToNative" in project "/Users/troy/Projects/etst/etst/etst.csproj".-- FAILED


Xamarin Studio
Version 5.5 (build 198)
Installation UUID: 4b991e3f-5b17-407e-970d-153a6e5764e2
Runtime:
	Mono 3.10.0 ((detached/ac51002)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000016

Apple Developer Tools
Xcode 6.1 (6307)
Build 6A1030

Xamarin.Mac
Version: 1.11.0.1 (Indie Edition)
Comment 33 Rolf Bjarne Kvinge [MSFT] 2014-09-22 05:50:28 UTC
Sebastien / QA: can you try to reproduce the MT9008 error with the versions from comment #29?
Comment 34 Chris Hamons 2014-09-22 09:29:42 UTC
@troy - The fix hasn't made it to the OS X 10.10 preview branch yet, so the alpha channel won't be fixed. Can you try beta or stable?
Comment 35 PJ 2014-09-22 12:01:58 UTC
As this issue affects both Mac and iOS, we'll be splitting the bug in two.

Contrary to my latest update, we'll move this one back into the iOS category to work on the issue that Magnus is reporting in comment 29 and comment 31. Sorry for the spam.

It is not currently reproducible for us using the builds in comment 29, Mohit will update on that shortly. 

Troy, your issue is currently reproducible, we just haven't released a new version of the 1.11 Alpha series yet after the required changes were made to Xamarin Studio. We'll split off a new bug to track the resolution there.
Comment 36 Mohit Kheterpal 2014-09-22 12:55:49 UTC
I have tried to reproduce this error with the builds provide in comment 29, and I am not able to reproduce it with Indie license.

And I am able to reproduce this issue with xam.mac 1.11.0.1 with Indie license and I have filed separate issue for xam.mac i.e. bug 23258

Thanks
Comment 37 Sebastien Pouliot 2014-09-22 16:43:42 UTC
I also could not duplicate this error using Indie and the version in comment #29 (on Mavericks).

@Magnus could you add "-v -v -v -v" to your current project options (Additional mtouch arguments), do a Clean, then a Build and attach (or paste) the full build log into this bug report ? thanks!
Comment 38 troy-dawson 2014-09-22 20:45:47 UTC
tried beta channel still seeing

MMPTASK: error MM9008: Building from the command-line requires a Business license.

when building a new Mac unified project

Xamarin Studio
Version 5.4 (build 240)
Installation UUID: 4b991e3f-5b17-407e-970d-153a6e5764e2
Runtime:
	Mono 3.8.0 ((no/45d0ba1)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000009

Apple Developer Tools
Xcode 6.1 (6307)
Build 6A1030

Xamarin.Mac
Version: 1.10.0.10 (Indie Edition)
Comment 39 Rolf Bjarne Kvinge [MSFT] 2014-09-23 06:23:57 UTC
@Troy, please use bug #23258 for this error with Xamarin.Mac, so that it doesn't end up too confusing.
Comment 40 JeffD 2014-10-04 11:27:17 UTC
Still has the problem

=== Xamarin Studio ===

Version 5.5 (build 227)
Installation UUID: 5fbace09-7618-400f-ab91-08c1223a843c
Runtime:
	Mono 3.10.0 ((detached/633e444)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000019

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.iOS ===

Version: 8.2.0.193 (Indie Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Xamarin.Android ===

Not Installed

=== Xamarin.Mac ===

Version:

=== Build Information ===

Release ID: 505000227
Git revision: 7b721eeec7a2fa4c4f4de0ecd2aed4dc25edac95
Build date: 2014-10-02 15:53:38-04
Xamarin addins: 99ed56b428b31eba1efaace4d82188d6f334e6ca

=== Operating System ===

Mac OS X 10.10.0
Darwin JeanFracoissMBP 14.0.0 Darwin Kernel Version 14.0.0
    Tue Sep 23 23:01:41 PDT 2014
    root:xnu-2782.1.97~6/RELEASE_X86_64 x86_64
Comment 41 JeffD 2014-10-04 11:51:36 UTC
Updating to xcode 6.1 fixed the problem
Comment 42 Magnus Johansson 2014-10-04 15:16:31 UTC
Just installed the latest "stable" 5.5, guess what:
Error MT9008: Building from the command-line requires a Business license. (MT9008) 


I already have Xcode 6.1 installed, so that's not a valid workaround.
"Stable" 5.4 didn't have this problem for me.

Seriously guys, why is this so hard to fix?



=== Xamarin Studio ===

Version 5.5 (build 227)
Installation UUID: 9428fc90-fb5b-413b-abd8-1f6daca5faf3
Runtime:
	Mono 3.10.0 ((detached/47db868)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000019

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.Android ===

Version: 4.18.0 (Indie Edition)
Android SDK: /Users/magnusjohansson/Projects/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.7.0_21"
Java(TM) SE Runtime Environment (build 1.7.0_21-b12)
Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01, mixed mode)

=== Xamarin.iOS ===

Version: 8.2.0.193 (Indie Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Xamarin.Mac ===

Version:

=== Build Information ===

Release ID: 505000227
Git revision: 7b721eeec7a2fa4c4f4de0ecd2aed4dc25edac95
Build date: 2014-10-02 15:53:38-04
Xamarin addins: 99ed56b428b31eba1efaace4d82188d6f334e6ca

=== Operating System ===

Mac OS X 10.10.0
Darwin Magnuss-MBP.perfinica.local 14.0.0 Darwin Kernel Version 14.0.0
    Tue Sep 23 23:01:41 PDT 2014
    root:xnu-2782.1.97~6/RELEASE_X86_64 x86_64
Comment 43 Rolf Bjarne Kvinge [MSFT] 2014-10-14 08:07:49 UTC
@Magnus: can you download the following project: http://files.xamarin.com/~rolf/xs-diagnostics.zip, run the project in Xamarin Studio and attach the file /tmp/xs-diagnostics.log which the project creates on your system?
Comment 44 troy-dawson 2014-10-14 09:18:16 UTC
Created attachment 8411 [details]
output of script

ran script per request
Comment 45 Magnus Johansson 2014-10-14 13:36:20 UTC
@Rolf, done.

However, I must say that currently I don't see this issue.
It probably went away when I upgraded Xcode to 6.1.
But, I saw it once directly after the upgrade, did a clean/rebuild and haven't seen it since.
Granted, I have only worked with one specific solution/project the last week.
/M
Comment 46 Magnus Johansson 2014-10-14 13:36:55 UTC
Created attachment 8413 [details]
Output from Diagnostics project
Comment 47 troy-dawson 2014-10-14 22:46:03 UTC
creating & building a new unified Xamarin.Mac project still gives me this error.
Comment 48 Rolf Bjarne Kvinge [MSFT] 2014-10-15 02:16:32 UTC
@Troy, which version of Xamarin.Mac do you have now?
Comment 49 troy-dawson 2014-10-15 07:25:29 UTC
Xamarin.Mac
Version: 1.11.0.1 (Indie Edition)
Comment 50 Chris Hamons 2014-10-15 08:50:37 UTC
Try the beta channel. We're updating Alpha hopefully this week to have the fix.
Comment 51 JeffD 2014-10-17 17:28:32 UTC
New update today (stable channel), problem has reappeared. I knew I shouldn't press that "Update" button...

Xamarin Studio
Version 5.5.2 (build 3)
Installation UUID: 5fbace09-7618-400f-ab91-08c1223a843c
Runtime:
	Mono 3.10.0 ((detached/e204655)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000023

Apple Developer Tools
Xcode 6.1 (6539)
Build 6A1042b

Xamarin.Mac
Version:

Xamarin.iOS
Version: 8.2.0.207 (Indie Edition)
Hash: 3bf072d
Branch: 
Build date: 2014-10-15 21:44:26-0400

Xamarin.Android
Not Installed

Build Information
Release ID: 505020003
Git revision: 6d4c806e383ba366b15fbccca9ddc1ba94f8d5ad
Build date: 2014-10-15 15:00:36-04
Xamarin addins: 069ddd29bb70a42238142eee9bac21a5e4b2f9f9

Operating System
Mac OS X 10.10.0
Darwin JeanFracoissMBP 14.0.0 Darwin Kernel Version 14.0.0
    Tue Sep 23 23:01:41 PDT 2014
    root:xnu-2782.1.97~6/RELEASE_X86_64 x86_64
Comment 52 JeffD 2014-10-17 17:47:29 UTC
Now on Beta 5.6 (build 273) and have the same result. So frustrating...
Comment 54 Rolf Bjarne Kvinge [MSFT] 2014-10-20 05:08:04 UTC
@JeffD, can you download and run the project from comment 43 and attach the output as explained there?
Comment 55 Rolf Bjarne Kvinge [MSFT] 2014-10-24 12:56:38 UTC
We've identified an issue when updating Xamarin Studio on Yosemite, where this would happen in (only) the automatically restarted Xamarin Studio after the update. The workaround is to restart Xamarin Studio after updating.

If anyone is able to reproduce this issue *after* restarting Xamarin Studio, please run the project form comment 43, attach the output and reopen the bug.

*** This bug has been marked as a duplicate of bug 24011 ***
Comment 56 Saurabh 2014-11-07 01:02:33 UTC
I have checked this Issue after upgrading X.S 5.5.4 (Build 11) to Beta/Alpha
5.6.3 I have created Classic API application and build the application when
having STARTER license on disk. Application gets build successfully. Even I
have checked with iOS 8 sample 'ImageInverter' This is also builds
successfully. I am not seeing error "Building from the command-line requires a
Business license" 

X.S 5.5.4 (Build 11)
Git revision: eeee7455222308275e32ba67790c0b42d904292b
Upgraded to Beta and Alpha 5.6.3
X.iOS 8.4.0-28