Bug 2242 - After compiling(with AOT compiler) and running the code, it turned out that it was twice as slow as compiling with JIT.
Summary: After compiling(with AOT compiler) and running the code, it turned out that i...
Status: RESOLVED NORESPONSE
Alias: None
Product: Runtime
Classification: Mono
Component: JIT ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-11-29 05:03 UTC by ali
Modified: 2017-07-07 18:27 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description ali 2011-11-29 05:03:43 UTC
- Apparently there's no difference between Debug and Release version, through MonoDevelop, from the speed point of view, in my case: it's a simple ray tracing  console application which involved threading. 
- Also, is the release version of MonoDevelop the same as compiling the code with AOT by command?
Comment 1 Rodrigo Kumpera 2013-09-09 11:54:58 UTC
AOT doesn't necessarily means faster code. Please attach a test that shows this slowdown.
Comment 2 ali 2013-09-09 12:29:28 UTC
Oh! Thanks for quick response by the way :)
I will do that. 
thanks anyway.
Comment 3 Ludovic Henry 2017-07-07 18:27:21 UTC
If it's still much slower with latest mono version, please feel free to reopen the bug. Thank you.