Bug 22354 - autorelease pool corrupted
Summary: autorelease pool corrupted
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: 7.2.6
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-08-26 03:33 UTC by renan jegouzo
Modified: 2015-01-13 11:34 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
crash.log (35.95 KB, application/octet-stream)
2014-08-26 03:39 UTC, renan jegouzo
Details
crash.symbol.log (37.43 KB, text/plain)
2014-08-27 18:56 UTC, renan jegouzo
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description renan jegouzo 2014-08-26 03:33:58 UTC
I have an application that works well, but if I send it in background, it crash when coming back foreground.
with this error in the organizer console:

<Error>: objc[399]: autorelease pool page 0x172b6000 corrupted
	  magic 0x00000000 0x00000000 0x00000000 0x00000000
	  pthread 0x0

It wasn't happening before, I think it's one of the last Xamarin update who added that.
I have no unsafe code in this project.

Xamarin Studio
Version 5.2.1 (build 1)
Installation UUID: 2a46676f-5eb8-4569-9aa7-630cd15bdfc2
Runtime:
	Mono 3.6.0 ((no/f540f8a)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 306000039

Apple Developer Tools
Xcode 5.1.1 (5085)
Build 5B1008

Xamarin.Mac
Version:

Xamarin.Android
Version: 4.14.0 (Business Edition)
Android SDK: /Users/renanyoy/android sdk
	Supported Android versions:
		2.3   (API level 10)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

Xamarin.iOS
Version: 7.2.6.28 (Business Edition)
Hash: 606f31a
Branch: 
Build date: 2014-08-01 15:27:48-0400

Build Information
Release ID: 502010001
Git revision: d06832ce9807d6be24aca225457e8b37c7669f6f
Build date: 2014-08-07 12:10:47-04
Xamarin addins: 1de032531be4cecf2f39dbee3b87aac78204058c

Operating System
Mac OS X 10.9.4
Darwin macbook.home 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 1 renan jegouzo 2014-08-26 03:39:51 UTC
Created attachment 7794 [details]
crash.log
Comment 2 Prashant manu 2014-08-26 05:16:38 UTC
Could you please provide us the test steps you followed. If possible please
attach a small complete project that demonstrates this behavior.

Also can you please add the logs from the following places?:
On XS IDE Log  Location: XS>Help> Open Log Directory> IDE.log file (with latest
timestamp)
Comment 3 renan jegouzo 2014-08-26 07:56:27 UTC
I launch the app
I press the home button on the device
I press the icon app on the device
and it crash
Comment 4 renan jegouzo 2014-08-26 08:04:15 UTC
it's multithreaded app
Comment 5 Alex Soto [MSFT] 2014-08-27 16:14:18 UTC
Hello Renan 

Unfortunately the crash log you provided us is not symbolicated, could you provide us one? in a better case a sample demoing this issue?

Cheers
Comment 6 renan jegouzo 2014-08-27 18:56:52 UTC
Created attachment 7842 [details]
crash.symbol.log
Comment 7 renan jegouzo 2014-08-27 19:23:23 UTC
 it's an open gl app, that is also a music player in background.
Comment 8 renan jegouzo 2014-09-01 10:41:19 UTC
where can I download an older xamarin.ios to build and publish the app ?
Comment 10 renan jegouzo 2014-09-09 18:40:41 UTC
any fixes ? the release date of this app is targeted for the 1st october.
Comment 14 renan jegouzo 2014-09-13 03:45:44 UTC
no, I'm not paid for that.
Comment 15 renan jegouzo 2014-09-13 03:46:57 UTC
in fact I paid for a working product and that's not the case, I'm trying to use your software since 3 years,and there is always new blocking bugs on it.
Comment 16 renan jegouzo 2014-09-13 04:15:04 UTC
at https://store.xamarin.com/account/my/subscription/downloads

I can find the version used in  june 2014 for osx (7 june precisely), is it available somewhere ?
Comment 17 renan jegouzo 2014-09-13 04:16:12 UTC
I can't find*
Comment 19 renan jegouzo 2014-09-18 05:03:24 UTC
I found the reason of this bug, it was a problem with my own NSAutoreleasePool management.
thanks for your help.
Comment 20 renan jegouzo 2014-09-18 05:03:46 UTC
fixed
Comment 21 Mohit Kheterpal 2015-01-13 11:34:50 UTC
As per comment 20, this issue is fixed.

Hence closing this issue by marking it as Verified.